2099_Frame Polygonal Line(测试正确但是wrong answer,求解)(对输入格式的控制)

You are going to read a sequence of pairs of integer numbers. Each pair represents the Cartesian coordinates of a point in a 2-dimentional plane. The first number is the x coordinate, while the second is that of y. The sequence represents a polygonal line. Your task is to draw a rectangle with minimal length of sides that exactly surrounds the polygonal line. The sides of the rectangle are parallel to x- and y-axis, respectively.


Input

Input consists of several test cases. For each case, a sequence of coordinates is given. Each pair of x and y occupies a line, with |x| and |y| less than 2^31. The sequence is terminated with a pair of 0's. Note that (0, 0) will never be considered as a point on any of the polygonal lines. An empty polygonal line signals the end of input.


Output

For each test case, print in one line two pairs of numbers, which are the south-west and north-east corners of the surrounding rectangle. The numbers must be separated by one space as is indicated in the samples.


Sample Input

12 56
23 56
13 10
0 0
12 34
0 0
0 0


Sample Output

12 10 23 56
12 34 12 34



Author: WENG, Kai

Source: Zhejiang University Local Contest 2004

***************************************************************************************************************

//找出最小的x,y最大的x,y输出
#include<iostream>
using namespace std;
int main()
{
int x_max,x_min,y_max,y_min;
int x,y;
bool flag1,flag2;
while(true)
{   
flag1=flag2=true;
while(cin>>x>>y&&x&&y)
{   
flag2=false;//标记连续输入两对0的情况
if(flag1)//输入的第一次,有别于其他
{
x_max=x_min=x;
y_max=y_min=y;
flag1=false;
continue;
}
if(x>x_max)
x_max=x;
if(x<x_min)
x_min=x;
if(y>y_max)
y_max=y;
if(y<y_min)
y_min=y;
}
if(flag2)
break;
cout<<x_min<<" "<<y_min<<" "<<x_max<<" "<<y_max<<endl;
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值