In your job at Albatross Circus Management (yes, it's run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc.
Input
The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer,n, which is the number of strings in the set, followed by n strings, one per line, sorted in nondescending order by length. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.
Output
For each input set print "SET n" on a line, where n starts at 1, followed by the output set as shown in the sample output.
Example input: | Example output: |
7 Bo Pat Jean Kevin Claude William Marybeth 6 Jim Ben Zoe Joey Frederick Annabelle 5 John Bill Fran Stan Cece 0 | SET 1 Bo Jean Claude Marybeth William Kevin Pat SET 2 Jim Zoe Frederick Annabelle Joey Ben SET 3 John Fran Cece Stan Bill |
Source: Mid-Central USA 2004
***************************************************************************************************************
//题意:将原来非降序的一组名字按对称的顺序输出,具体为:(数组下标从1开始)先奇数升序的输出,然后偶数降序输出
#include<iostream>
#include<string>
using namespace std;
struct list
{
string name;
};
int main()
{
list order[16];
int n,i,count=1;
while(cin>>n&&n)
{
for(i=1;i<=n;i++)
cin>>order[i].name;
cout<<"SET "<<count++<<endl;
for(i=1;i<=n;i+=2)
cout<<order[i].name<<endl;
if(n%2==0)
for(i=n;i>=1;i-=2)
cout<<order[i].name<<endl;
else
for(i=n-1;i>=1;i-=2)
cout<<order[i].name<<endl;
}
return 0;
}