Java compiler level does not match the version of the installed Java project facet.解决方法

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/aspnet2002web/article/details/50679678
从别的地方拿来的代码,因为环境不一样,打开总是会出现一些错误。当编译的时候出现Java compiler level does not match the version of the installed Java project facet.错误,可以在.settings目录找到org.eclipse.wst.common.project.facet.core.xml文件:
<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <runtime name="Apache Tomcat v6.0"/>
  <fixed facet="jst.web"/>
  <fixed facet="jst.java"/>
  <installed facet="jst.web" version="2.5"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
  <installed facet="jst.java" version="1.6"/>
</faceted-project>
把<installed facet="jst.java" version="1.6"/>里的version版本修改为指定版本

阅读更多

没有更多推荐了,返回首页