hdu 1712 ACboy needs your help

ACboy needs your help
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5029 Accepted Submission(s): 2720

Problem Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

Sample Input

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

Sample Output

3
4
6

思路:经典的分组背包题目。有多组数值选择,每组数值最多选一个,则对每一组数值,状态只有两种:取一个数值或不取值。

动态转移方程:dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - cost[k]] + val[i][k]); dp[i][j] 表示前i组花费为j时的最优解。

#pragma comment(linker, "/STACK:1024000000,1024000000") //黑科技
#include <stdio.h>
#include <map>
#include <vector>
#include <queue>
#include <iostream>
#include <string.h>
#include <algorithm>
#include <string>
#include <math.h>
using namespace std;
typedef long long LL;
const double eqs=1e-9;
#define maxd 105
int cost[maxd][maxd];
int val[maxd][maxd]; 
int dp[maxd][maxd];
int main()
{
    int n, m;
    while(scanf("%d %d", &n, &m) != EOF && n)
    {
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= m; j++) 
            {
                scanf("%d", &val[i][j]);
                cost[i][j] = j;
            }
        //可优化(删去明显不可能的情况) 
        for(int i = 1; i <= n; i++) //组数 
            for(int j = m; j >= 0; j--)//
                for(int k = 1; k <= m; k++)
                {
                    if (j < cost[i][k]) continue;
                    int tem = max(dp[i - 1][j], dp[i - 1][j - cost[i][k]] + val[i][k]);
                    dp[i][j] = max(dp[i][j], tem);
                }
        printf("%d\n", dp[n][m]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值