2021_GDUT_新生专题训练_动态规划基础

G - 最少拦截系统

 某国为了防御敌国的导弹袭击,发展出一种导弹拦截系统.但是这种导弹拦截系统有一个缺陷:虽然它的第一发炮弹能够到达任意的高度,但是以后每一发炮弹都不能超过前一发的高度.某天,雷达捕捉到敌国的导弹来袭.由于该系统还在试用阶段,所以只有一套系统,因此有可能不能拦截所有的导弹.
怎么办呢?多搞几套系统呗!你说说倒蛮容易,成本呢?成本是个大问题啊.所以俺就到这里来求救了,请帮助计算一下最少需要多少套拦截系统.

Input
输入若干组数据.每组数据包括:导弹总个数(正整数),导弹依此飞来的高度(雷达给出的高度数据是不大于30000的正整数,用空格分隔)
Output
对应每组数据输出拦截所有导弹最少要配备多少套这种导弹拦截系统.
Sample Input

8 389 207 155 300 299 170 158 65

Sample Output

2
#include<iostream>
#include<cstring>
using namespace std;
#include<algorithm>
int a[10000];//
int main()
{
    int n,cnt=0;
    while(~scanf("%d",&n))
    {
        cnt=0;
        memset(a,0,sizeof a);
        for(int i=1;i<=n;i++)
        {
            int tmp;
            scanf("%d",&tmp);
            if(a[cnt]<tmp)
            {
                a[++cnt]=tmp;
            }
            else
            {
                for(int i=1;i<=cnt;i++)
                {
                    if(a[i]>=tmp)
                    {
                        a[i]=tmp;
                        sort(a+1,a+1+cnt);
                        break;
                    }
                }
            }
        }
        cout<<cnt<<endl;
    }
    return 0;
}

M - Discovering Gold

You are in a cave, a deep cave! The cave can be represented by an 1 x N grid. Some cells in the cave might contain gold!

Initially, you are in position 1. In each move, you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside of the cave, you keep throwing the dice again until you get a suitable result. When you reach the Nth position you stop your journey.

Given the information about the cave, you have to find the expected amount of gold you can collect using the procedure described above.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and not greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will beignored.

Sample Input

3

1
101

2
10 3

3
3 6 9

Sample Output

Case 1: 101
Case 2: 13.000000
Case 3: 15.0000000000

方法:只要从1开始,向后累计tmp=min(tmp,6);的概率,然后单个概率乘以大小的和就是期望;

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
double a[110],dp[110];
int main()
{
    int t;
    cin>>t;
    for(int l=1;l<=t;l++)
    {
        int n;
        cin>>n;
        memset(dp,0,sizeof dp);
        dp[1]=1;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
        }
        for(int i=1;i<n;i++)
        {
            int tmp=n-i;
            tmp=min(tmp,6);
            for(int j=1;j<=tmp;j++)
            {
                dp[i+j]+=dp[i]*(1.0/tmp);
            }
        }
        dp[n]=dp[1];
        double sum=0;
        for(int i=1;i<=n;i++)
        {
            sum+=a[i]*dp[i];
        }
        printf("Case %d: %lf\n", l,sum);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值