poj_3256_Cow Picnic

The cows are having a picnic! Each of Farmer John's K (1 ≤ K ≤ 100) cows is grazing in one of N (1 ≤ N ≤ 1,000) pastures, conveniently numbered 1...N. The pastures are connected by M (1 ≤ M ≤ 10,000) one-way paths (no path connects a pasture to itself).

The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.

Input

Line 1: Three space-separated integers, respectively: K, N, and M
Lines 2.. K+1: Line i+1 contains a single integer (1.. N) which is the number of the pasture in which cow i is grazing.
Lines K+2.. M+ K+1: Each line contains two space-separated integers, respectively A and B (both 1.. N and A != B), representing a one-way path from pasture A to pasture B.

Output

Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.

Sample Input

2 4 4
2
3
1 2
1 4
2 3
3 4

Sample Output

2

Hint

The cows can meet in pastures 3 or 4.
 
dfs题,搜索每只牛能到达的位置。
 
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 1000005
int prime[N];
int pn=0;
int vis[10005];
int st[10005];
int val[10005];
int a[10005];
int b[10005];
int h[10005];
int k,n,m;
void dfs(int x)
{
    val[x]=1;vis[x]++;
    for(int i=h[x];i;i=a[i])
    {
            if(!val[b[i]])
                dfs(b[i]);

    }
}
int main()
{
    //int k,n,m;
    cin>>k>>n>>m;
    int num=0;
    for(int i=1;i<=k;i++)
    {
        cin>>st[i];
        //vis[st[i]]++;
    }
    int x,y;
    for(int i=1;i<=m;i++)
    {
        cin>>x>>y;
        a[i]=h[x];
        b[i]=y;
        h[x]=i;

    }
    for(int i=1;i<=k;i++)
    {
        memset(val,0,sizeof(val));
        dfs(st[i]);
    }
    for(int i=1;i<=n;i++)
    {
        if(vis[i]==k)
            num++;
    }
    cout<<num<<endl;
}

  

转载于:https://www.cnblogs.com/ygtzds/p/8039968.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值