判断这两个数组中是否有相同的数、
Description
给定两个整数数组,判断这两个数组中是否有相同的数。Input
第一行是一个正整数T,表示测试数据组数。
每组测试数据中,第一行有两个正整数n,m,分别表示两个数组的长度。
第二行有n个整数,表示第一个数组。第三行有m个整数,表示第二个数组。
(1<=T<=10,1<=n,m<=100000)
(数组中的整数的绝对值<=1000000000)Output
每组数据输出一行,如果两个数组中存在相同的数,输出Yes,否则输出No.
Sample Input
2
3 4
1 2 3
3 4 5 6
3 3
1 3 5
2 4 6
Sample Output
Yes
No
简单思路1:
暴力法O(n^2)直接解决。虽然结果TLE,但这是最先想到的方法。
#include<iostream>
using namespace std;
int main()
{
int group;
cin >> group;
while (group > 0)
{
int len1, len2;
cin >> len1 >> len2;
int *n1 = new int[len1];
int *n2 = new int[len2];
for(int i = 0; i < len1; i++)
{
cin >> n1[i];
}
for(int j = 0; j < len2; j++)
{
cin >> n2[j];
}
bool same = false;
for(int i = 0; i < len1; i++)
{
if(same == true)
{
break;
}