判断这两个数组中是否有相同的数(C++)

判断这两个数组中是否有相同的数、

Description
给定两个整数数组,判断这两个数组中是否有相同的数。

Input
第一行是一个正整数T,表示测试数据组数。
每组测试数据中,第一行有两个正整数n,m,分别表示两个数组的长度。
第二行有n个整数,表示第一个数组。第三行有m个整数,表示第二个数组。
(1<=T<=10,1<=n,m<=100000)
(数组中的整数的绝对值<=1000000000)

Output
每组数据输出一行,如果两个数组中存在相同的数,输出Yes,否则输出No.

Sample Input

2
3 4
1 2 3
3 4 5 6
3 3
1 3 5
2 4 6

Sample Output

Yes
No

简单思路1:
暴力法O(n^2)直接解决。虽然结果TLE,但这是最先想到的方法。

#include<iostream>
using namespace std;

int main()
{
    int group;
    cin >> group;
    while (group > 0)
    {
        int len1, len2;
        cin >> len1 >> len2;
        int *n1 = new int[len1];
        int *n2 = new int[len2];
        for(int i = 0; i < len1; i++)
        {
            cin >> n1[i];
        }
        for(int j = 0; j < len2; j++)
        {
            cin >> n2[j];
        }
        bool same = false;
        for(int i = 0; i < len1; i++)
        {
            if(same == true)
            {
                break;
            }
            
C++中,判断两个数组中有多少个连续相等的字,你可以采用遍历的方式进行比较。以下是一个简单的步骤: 1. 定义两个指针,一个指向第一个数组(arr1),另一个指向第二个数组(arr2)。 2. 使用嵌套循环,对于每个元素,检查它是否等于相邻元素。如果相等,并且接下来的元素也相等,就增加连续相等的量计器。 3. 当遍历完成后,返回这个计器作为结果。 ```cpp #include <iostream> #include <vector> int countConsecutiveEqual(std::vector<int>& arr1, std::vector<int>& arr2) { int n = arr1.size(); int m = arr2.size(); if (n != m) { return -1; // 如果数组长度不匹配,无法直接比较 } int consecutiveCount = 0; for (int i = 0; i < n; ++i) { if (arr1[i] == arr2[i]) { // 检查当前元素是否相等 int j = i + 1; while (j < n && arr1[j] == arr2[j]) { // 遍历直到不相等为止 ++consecutiveCount; ++j; } i = j - 1; // 更新指针位置,继续下一段连续的比较 } else { consecutiveCount = 0; // 不相等则从头开始计 } } return consecutiveCount; } // 测试例子 int main() { std::vector<int> arr1 = {1, 2, 2, 3, 4, 4, 5}; std::vector<int> arr2 = {1, 2, 2, 3, 4, 4, 6}; int result = countConsecutiveEqual(arr1, arr2); if (result != -1) { std::cout << "There are " << result << " consecutive equal numbers." << std::endl; } else { std::cout << "Arrays cannot be compared directly due to different lengths." << std::endl; } return 0; } ```
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值