UVA - 101 The Blocks Problem

Description

Download as PDF

Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.

The Problem 

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are  n blocks on the table (numbered from 0 to  n-1) with block  b i adjacent to block  b i+1 for all  $0 \leq i < n-1$ as shown in the diagram below:
 
\begin{figure}\centering\setlength{\unitlength}{0.0125in} %\begin{picture}(2......raisebox{0pt}[0pt][0pt]{$\bullet\bullet \bullet$ }}}\end{picture}\end{figure}
Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

    where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and bto their initial positions.

  • move a over b

    where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.

  • pile a over b

    where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.

  • quit

    terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

The Input 

The input begins with an integer  n on a line by itself representing the number of blocks in the block world. You may assume that 0 <  n< 25.

The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output 

The output should consist of the final state of the blocks world. Each original block position numbered i ( $0 \leq i < n$ where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output 

 0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:



Miguel Revilla
2000-04-06

/*
    Coder: Shawn_Xue
    Date: 2015.4.4
    Result: AC
*/
#include <cstdio>
#include <string>
#include <vector>
#include <iostream>
using namespace std;

const int maxn = 30;
int n;
vector <int> pile[maxn]; // 每个pile[i] 是一个vector,即代表标号为i+1的木块堆

void find_block(int a, int &p, int &h)
{
    //类似二位数组的遍历
    for(p = 0; p < n; p++)  //遍历不同木块堆
        for(h = 0; h < pile[p].size(); h++) //遍历同一木块堆
        if(pile[p][h] == a) //找到标号为a的木块,是第p个木块堆的第h个
        return ;
}
//把p上面的木块放回原处
void clear_above(int p, int h)
{
    for(int i = h+1;  i < pile[p].size(); i ++)//从b的上面开始
    {
        int b = pile[p][i];
        pile[b].push_back(b);//放回原处
    }
    pile[p].resize(h+1);//p的长度重置为h+1,第一块为0
}

void pile_over(int p, int h, int p2)
{
    for(int i = h; i < pile[p].size(); i ++)
    {
        pile[p2].push_back(pile[p][i]);//放到p2中,上下顺序不变
    }
    pile[p].resize(h);
}

void print()
{
    for(int i = 0; i < n; i ++)
    {
        printf("%d:",i);
        for(int j = 0; j < pile[i].size(); j++)
            printf(" %d",pile[i][j]);
        cout << endl;
    }
}
int main()
{
    int a, b;
    cin >> n;
    string s1, s2;  //存储指令
    for(int i = 0; i < n; i ++)
    {
        //push_back()把数据i添加在vector pile[i]的尾部
        //pop_back()把数据i从vector pile[i]的尾部删除
        pile[i].push_back(i);   //初始化从左到右的n个木块堆,每个木块堆放置一个木块,并编号为i
    }
        while(cin >> s1 >> a >> s2 >> b)
        {
            int pa, pb, ha, hb;
            find_block(a, pa, ha);  //找到a,位于pa个木块堆的ha上
            find_block(b, pb, hb);  //找到b,位于pb个木块堆的hb上
            if(pa == pb)//a,b位于同一堆
                continue;
            if(s1 == "quit")
                break;
            if(s2 == "onto")//string类中==被重载,可以直接比较。不用调用strcmp
                clear_above(pb, hb);
            if(s1 == "move")
                clear_above(pa, ha);
            pile_over(pa, ha, pb);
        }
        print();
        return 0;

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值