HDU - 1260 Tickets(简单 dp)

Tickets

 

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 

InputThere are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 
OutputFor every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 
Sample Input

2
2
20 25
40
1
8

Sample Output

08:00:40 am
08:00:08 am

题意:n 个排好队的人买票(从后往前给出),现在有这 n 个人单独买票花的时间和 与前一个人一起买票花的时间,问最快售票完成需要多久
。。。设 dp[i] 表示到第 i 个人买票花的时间,有状态转移方程 dp[i] = min(dp[i - 1] + alone[i],dp[i - 2] + together[i])
初始状态,dp[1] = alone[1]

#include<bits/stdc++.h>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define ull unsigned LL
#define ls i << 1
#define rs (i << 1) + 1
#define INT(t) int t; scanf("%d",&t)

using namespace std;

const int maxn = 2010;
int a[maxn],b[maxn];
int dp[maxn];

int main() {
    int t; scanf("%d",&t);
    while(t --){
        int n; scanf("%d",&n);
        for(int i = 1;i <= n;++ i)
            scanf("%d",&a[i]);
        for(int i = 2;i <= n;++ i)
            scanf("%d",&b[i]);
        dp[1] = a[1];
        for(int i = 2;i <= n;++ i){
            dp[i] = min(dp[i - 1] + a[i],dp[i - 2] + b[i]);
        }
        int ans = dp[n];
        int h = 8,m = 0,s = 0;
        s = dp[n] % 60;
        m = dp[n] / 60;
        h += m / 60;
        m = m % 60;
        if(h < 10) printf("0"); printf("%d:",h);
        if(m < 10) printf("0"); printf("%d:",m);
        if(s < 10) printf("0"); printf("%d ",s);
        printf("am\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/rookie-acmer/p/11258373.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值