HDU-1260 Tickets(简单DP)

2 篇文章 0 订阅

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 

Sample Input

2
2
20 25
40
1
8

Sample Output

08:00:40 am
08:00:08 am

题意为:

就是一个人卖票,他8点开始上班,票既可以单卖也可以一次卖两张,给出K个人的单独买票时间和K-1个相邻的两个人一起买票的时间,问一共花费的最小时间。

对于每个状态,我们都能通过前一个人单买一张票或者相邻的两个人一起买票得到

于是可以得到状态转移方程:res[i] = min(res[i-1] + arr1[i],res[i-2] + arr2[i]);

其中res存储结果,arr1存储单买所需的时间,arr2存储相邻的两个人一起买票所需的时间

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>

using namespace std;

int main() {
    int t, n, arr1[2001],arr2[2001],res[2000],tmp,h,m,s;
    scanf("%d",&t);
    while(t--) {
        memset(res,0,sizeof(res));
        h = 8;
        scanf("%d",&n);
        for(int i = 1;i <= n;i++){
            scanf("%d",&arr1[i]);
            res[i] = arr1[i];
        }
        for(int i = 2;i <= n;i++) {
            scanf("%d",&arr2[i]);
        }
        for(int i = 2;i <= n;i++) {
            res[i] = min(res[i-1] + arr1[i],res[i-2] + arr2[i]);
        }
        tmp = res[n];
        h += tmp / 3600;
        tmp %= 3600;
        m = tmp / 60;
        tmp %= 60;
        s = tmp;
        if(h >= 12)
            printf("%02d:%02d:%02d pm\n",h,m,s);
        else
            printf("%02d:%02d:%02d am\n",h,m,s);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值