sdutacm-数据结构上机测试4.1:二叉树的遍历与应用1

数据结构上机测试4.1:二叉树的遍历与应用1

TimeLimit: 1000MS Memory Limit: 65536KB

SubmitStatistic

Problem Description

输入二叉树的先序遍历序列和中序遍历序列,输出该二叉树的后序遍历序列。

Input

第一行输入二叉树的先序遍历序列;
第二行输入二叉树的中序遍历序列。

Output

输出该二叉树的后序遍历序列。

Example Input

ABDCEF

BDAECF

Example Output

DBEFCA

Hint

Author

#include<string.h>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
typedef struct node
{
   char data;
   struct node*l;
   struct node*r;
}tree;
void huifu(char *xian,char *zhong,int len)
{
  if(len==0)
  return ;
  tree *p = new tree;
  p->data = *xian;
  int i = 0;
  for(;i<len;i++)
  if(zhong[i]==*xian)
  {
     break;
  }
  huifu(xian+1,zhong,i);
  huifu(xian+i+1,zhong+i+1,len-i-1);
  cout<<p->data;
  return ;



}
int main()
{

   char xian[102],zhong[102];
   int i,len;
   scanf("%s%s",xian,zhong);
   len = strlen(xian);
   huifu(xian,zhong,len);
   cout<<endl;


}






/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 152KB
Submit time: 2017-02-07 15:04:24
****************************************************/

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值