sdutacm-数据结构实验之求二叉树后序遍历和层次遍历

数据结构实验之求二叉树后序遍历和层次遍历

TimeLimit: 1000MS Memory Limit: 65536KB

SubmitStatistic

Problem Description

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历和层序遍历。

Input

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

Output

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列。

Example Input

2

abdegcf

dbgeafc

xnliu

lnixu

Example Output

dgebfca

abcdefg

linux

xnuli

Hint

Author

ma6174

#include<string.h>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
typedef struct node
{
   char data;
   struct node*l;
   struct node*r;
}tree;
void huifu(char *zhong,char *hou,int len)
{
  if(len==0)
  return ;
  tree *p = new tree;
  p->data = *(hou+len-1);
  int i = 0;
  for(;i<len;i++)
  if(zhong[i]==*(hou+len-1))
  {
     break;
  }
   cout<<p->data;
  huifu(zhong,hou,i);
  huifu(zhong+i+1,hou+i,len-i-1);

  return ;

}
tree* huifu2(char *xian,char *zhong,int len)
{
   tree*head =new tree;
   if(len==0)
   return NULL;

   head->data = *(xian);
   int i = 0;
   for(;i<len;i++)
   {
       if(zhong[i]==*xian)
       break;

   }
   head->l = huifu2(xian+1,zhong,i);
   head->r = huifu2(xian+i+1,zhong+i+1,len-i-1);
   return head;


}
void last(tree*root)
{

   if(root)
   {

      last(root->l);
      last(root->r);
      cout<<root->data;

   }

}
void ccout(tree*root)
{
    queue<tree*>q;
    tree*p =NULL;
    if(root)
    {
      q.push(root);
    }
    while(!q.empty())
    {
        p = q.front();
        q.pop();
        cout<<p->data;
        if(p->l)
        {
           q.push(p->l);
        }
        if(p->r)
        {

           q.push(p->r);
        }

    }



}
int main()
{

   char hou[102],zhong[102],xian[102];
   int o;
   cin>>o;

   while(o--)
   {

    int len;
   scanf("%s%s",xian,zhong);
   len = strlen(zhong);
   tree* root;
   root = huifu2(xian,zhong,len);
   last(root);
   cout<<endl;
   ccout(root);
   cout<<endl;

   }


}






/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 164KB
Submit time: 2017-02-07 15:47:07
****************************************************/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值