求二叉树的层次遍历

求二叉树的层次遍历

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
已知一颗二叉树的前序遍历和中序遍历,求二叉树的层次遍历。
Input
输入数据有多组,输入T,代表有T组测试数据。每组数据有两个长度小于50的字符串,第一个字符串为前序遍历,第二个为中序遍历。
Output
每组输出这颗二叉树的层次遍历。
Example Input
2
abc
bac
abdec
dbeac
Example Output
abc
abcde
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int k;
char a[100],b[100];
struct bittree
{
    char data;
    struct bittree * ltree,* rtree;
};
void cengci(struct bittree * root)
{
    if(root==NULL)
    {
        return ;
    }
    int f,r;
    f=1;r=1;
    struct bittree * s[100],*p;
    s[1]=root;
    while(f<=r)
    {
        p=s[f++];
        printf("%c",p->data);
        if(p->ltree!=NULL)
        {
            s[++r]=p->ltree;
        }
        if(p->rtree!=NULL)
        {
            s[++r]=p->rtree;
        }
    }
}
struct bittree * create(int len,char * a,char * b)
{
    struct bittree * root;
    int i;
    root=(struct bittree *)malloc(sizeof(struct bittree));
    if(len==0)
    {
        root=NULL;
    }
    else
    {
        root->data=a[0];
        for(i=0;i<len;i++)
        {
            if(root->data==b[i])
            {
                break;
            }
        }
        root->ltree=create(i,a+1,b);
        root->rtree=create(len-i-1,a+i+1,b+i+1);
    }
    return root;
}
int main()
{
    int t,len;
    struct bittree * root;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        k=0;
        gets(a);
        gets(b);
        len=strlen(a);
        root=create(len, a, b);
        cengci(root);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值