Rightmost Digit 1061

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24421    Accepted Submission(s): 9324


思路: 这题结果是一个循环。而且每个结果只保留最后一位即可。

Problem Description
Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the rightmost digit of N^N.

Sample Input
  
  
2 3 4

Sample Output
 
 
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
#include<iostream>
using namespace std;
int main()
{
    int i=0;
    int a, b,m;
    cin>>i;
    while(i>0)
    {
        cin>>a;
        int b = a;
        m = 1;
        if(b>4)
        {
            b %= 4;
            b += 4;
        }
        a %= 10;
        while(b>0)
        {
            m *= a;
            m %= 10;
            b--;
        }
        cout<<m<<endl;
        i--;
    }
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值