hdu 4339 线段树 单点更新

题目:http://acm.hdu.edu.cn/showproblem.php?pid=4339

题意:


Problem Description
You are given two strings s1[0..l1], s2[0..l2] and Q - number of queries.
Your task is to answer next queries:
  1) 1 a i c - you should set i-th character in a-th string to c;
  2) 2 i - you should output the greatest j such that for all k (i<=k and k<i+j) s1[k] equals s2[k].
 

Input
The first line contains T - number of test cases (T<=25).
Next T blocks contain each test.
The first line of test contains s1.
The second line of test contains s2.
The third line of test contains Q.
Next Q lines of test contain each query:
  1) 1 a i c (a is 1 or 2, 0<=i, i<length of a-th string, 'a'<=c, c<='z')
  2) 2 i (0<=i, i<l1, i<l2)
All characters in strings are from 'a'..'z' (lowercase latin letters).
Q <= 100000.
l1, l2 <= 1000000.
 

Output
For each test output "Case t:" in a single line, where t is number of test (numbered from 1 to T).
Then for each query "2 i" output in single line one integer j.
 

Sample Input
  
  
1 aaabba aabbaa 7 2 0 2 1 2 2 2 3 1 1 2 b 2 0 2 3
 

Sample Output
  
  
Case 1: 2 1 0 1 4 1
 
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<memory.h>
using namespace std;
const int maxn=1000007;
int col[maxn<<2],sum[maxn<<2],t,cas=1;
char s1[maxn],s2[maxn];
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
void pushUP(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int rt,int l,int r)
{
    if(l==r)
    {
        if(s1[l]==s2[l]) col[l]=1;//相同为1
        else             col[l]=0;//不同为0
        sum[rt]=col[l];
        return;
    }
    int mid=(l+r)>>1;
    build(lson);
    build(rson);
    pushUP(rt);
}
void updata(int rt,int l,int r,int op,int pos,char c)
{
    if(l==r)
    {
        if(op==1) s1[l]=c;
        if(op==2) s2[l]=c;
        if(s1[l]==s2[l]) col[l]=1;
        else col[l]=0;
        sum[rt]=col[l];
        return;
    }
    int mid=(l+r)>>1;
    if(pos<=mid) updata(lson,op,pos,c);
    else  updata(rson,op,pos,c);
    pushUP(rt);
}
int query(int rt,int l,int r,int pos)
{
    if(l==r) return sum[rt];
    if(l<=pos&&pos<=r)
    {
        if(sum[rt]==r-l+1)
        {
            return r-pos+1;
        }
        else
        {
            int mid=(l+r)>>1,ans=0;
            if(pos<=mid)
            {
                ans+=query(lson,pos);
                if(ans==mid-pos+1)
                {
                    ans+=query(rson,mid+1);
                }
            }
            else ans+=query(rson,pos);
            return ans;
        }
    }
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s%s",(s1+1),(s2+1));
        int l1=strlen(s1+1);
        int l2=strlen(s2+1);
        int n=max(l1,l2);
        build(1,1,n);
        int m,op,idx,pos;
        char c[2];
        scanf("%d",&m);
        printf("Case %d:\n",cas++);
        while(m--)
        {
            scanf("%d",&op);
            if(op==2)
            {
                scanf("%d",&pos);
                printf("%d\n",query(1,1,n,pos+1));
            }
            else
            {
                scanf("%d%d%s",&idx,&pos,&c);
                updata(1,1,n,idx,pos+1,c[0]);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值