poj 1979 Red and Black

16 篇文章 0 订阅
Red and Black

Time Limit: 1000MS
Memory Limit: 30000K

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
</pre><pre code_snippet_id="1629469" snippet_file_name="blog_20160330_7_2627642" class="sio" name="code" style="white-space: pre-wrap; word-wrap: break-word; font-family: 'Courier New', Courier, monospace;">#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
using namespace std;
string grid[25];
bool vis[25][25];
int cnt, x, y;


void dfs(int i, int j)
{
    if(i>=y||i<0)
        return;
    if(j>=x||j<0)
        return;
    if (grid[i][j] == '#' || vis[i][j]) return;
    vis[i][j] = true;
    ++cnt;
    dfs(i - 1, j);
    dfs(i + 1, j);
    dfs(i, j - 1);
    dfs(i, j + 1);
}


int main()
{
    int i, j, xx, yy;
    while (cin >> x >> y && x)
    
    {
        ///memset(grid, '#', sizeof(grid));
        for (i=0; i<25; i++) grid[i] = '#';


        for(i=0; i<y; i++)
            cin >> grid[i];
        for (i=0; i < y; i++)
        {
            for (j = 0; j < x; j++)
            {
                if (grid[i][j] == '@')
                    xx = i, yy = j;
            }


        }
        memset(vis, false, sizeof(vis));
        cnt = 0;
        dfs(xx, yy);
        cout << cnt << endl;
    }
    return 0;
}
要注意防止dfs越界
<pre name="code" class="cpp">#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
const int dx[4] = {1,0,-1,0};
const int dy[4] = {0,1,0,-1};

char graph[50][50];
const int maxn = 30;
bool vis[maxn][maxn];
bool vist[maxn][maxn];
struct node
{
    int x,y;
};

node New,now;
node s;
int t;
int w,h;
queue<node> q;

void bfs()
{
    q.push(s);
    vis[s.x][s.y] = true;
    while(!q.empty())
    {
        now=q.front();
        q.pop();
t++;
        //起点也是黑格子。所以要计数
        for(int i=0; i<4; i++)
        {
            New.x = now.x+dx[i];
            New.y = now.y+dy[i];
            if(!vist[New.x][New.y])
                continue;
            if(vist[New.x][New.y]&&!vis[New.x][New.y]&&New.x>0 && New.x <=h && New.y>0 && New.y<=w)
            {
                q.push(New);
                vis[New.x][New.y]=true;

            }
        }

    }
    cout << t << endl;
}

int main()
{
    while(scanf("%d%d",&w,&h),w&&h)
    {
        t=0;
        memset(vis,false,sizeof(vis));
        memset(vist,false,sizeof(vist));
        for(int i=1; i<=h;i++)
        {
            for(int j=1;j<=w;j++)
            {
                 cin >> graph[i][j];

            }
        }
        for(int i=1; i<=h;i++)
        {
            for(int j=1;j<=w;j++)
            {
                if(graph[i][j] == '@')
                {
                    s.x = i;
                    s.y = j;

                }
                if(graph[i][j] == '.')
                {
                    vist[i][j] = true;
                }

            }
        }
        bfs();

    }
    return 0;
}


 
 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值