HDU1003 Max Sum(最大连续子序和、贪心、DP)

HDU1003 Max Sum(最大连续子序和、DP)

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1003


题目

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6


分析

此题题意让求最大连续字段和,可以用贪心和DP来做。
贪心:每次当总和变大时,更新结束点位置。若不增大则保持不变。若总和小于0,直接从下一位置开始计数。
DP:使用dp[i]表示到达i时,a[1]~a[i]的最大字段和。状态转移方程为dp[i] = max(dp[i-1]+a[i], a[i])


源码

贪心

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<utility>
#include<sstream>
#define mem0(x) memset(x,0,sizeof x)
#define mem1(x) memset(x,1,sizeof x)
#define mem11(x) memset(x,-1,sizeof x)

using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x7fffffff;
const int MAXN = 1e6+10;
const int MOD = 1000000007;

int main(){
    /*#ifdef LOCAL
    freopen("C:\\Users\\JuneLynn Bian\\Desktop\\in.txt","r",stdin);
    freopen(" C:\\Users\\JuneLynn Bian\\Desktop\\out.txt","w",stdout);
    #endif // LOCAL*/
    int t,n,start,endd,tmp,p;
    cin >> t;
    for(int i = 1; i <= t; i++){
        cin >> n;
        ll s = 0;
        int maxx = -INF;
        start = endd = p = 1;
        for(int j = 1; j <= n; j++){
            cin >> tmp;
            s += tmp;
            if(s > maxx){
                maxx = s;
                start = p;
                endd = j;
            }
            if(s < 0){
                s = 0;
                p = j+1;
            }
        }
        printf("Case %d:\n",i);
        printf("%d %d %d\n",maxx,start,endd);
        if(i != t)
            cout << endl;
    }
    return 0;
}

DP
留做思考题好了(懒==)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值