hdu-2717 Catch That Cow (BFS)

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9744    Accepted Submission(s): 3048


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
第一道BFS题
# include<cstdio>
# include<cstring>
# include<queue>
# include<algorithm>
# define MAXM 100000 + 100
using namespace std;
int num[MAXM];
int vis[MAXM];

void bfs(int start, int end)
{
	int now, next;
	int i, j;
	queue<int>q;
	q.push(start);	
	vis[start] = 1;	
	while(!q.empty())
	{
		now = q.front();
	    q.pop();
	    if(now == end) break;
	    next = now + 1;
	    if(!vis[next] && next <= end)
	    {
	    	num[next] = num[now] + 1;
	    	vis[next] = 1;
	    	q.push(next);	    	
		}
	    next = now - 1;
		if(!vis[next] && next >= 0)
	    {
	    	num[next] = num[now] + 1;
	    	vis[next] = 1;
	    	q.push(next);	    	
		}
		next = now * 2;
		if(!vis[next] && next <= MAXM)
	    {
	    	num[next] = num[now] + 1;
	    	vis[next] = 1;
	    	q.push(next);	    	
		}
	}
	printf("%d\n",num[end]);
}

int main()
{
	int i, j;
	int start, end;
	while(scanf("%d%d",&start,&end)!=EOF)
	{
		memset(vis, 0, sizeof(vis));
		memset(num, 0, sizeof(num));
		bfs(start, end);
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值