ACM-BFS之Catch That Cow——hdu2717

Catch That Cow

题目:http://acm.hdu.edu.cn/showproblem.php?pid=2717

Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


这道题本来很简单,叫我想复杂了,o(╯□╰)o囧啊。。。。

没想到暴力BFS就可以过。

我还在想 VIS数组是否有优化的选择,比如 用终点和当前点的距离差做标准等。。。

结果一直超内存。。。


后来,想干脆暴搜一次看看,

结果因为,我判断没写函数,直接判断,

if(vis[k.x]==0 && k.x>=0 && k.x<=100000)

因为if里的顺序问题,一直越界错误。。。(应该让判断范围在 判断数组内容前面)

然后又因为判断与0,100000 落了等号。。又WA一次。。


这个简单的题目,悲剧了好长时间。。。想哭了的说。。。


#include <iostream>
#include <queue>
#include <string.h>

using namespace std;
int finish;
bool vis[100011];
struct Coor
{
    int x,step;
};

bool judge(int x)
{
    if(x<0 || x>100000) return 0;
    if(vis[x]==1)   return 0;
    return 1;
}

int bfs(int start)
{
    memset(vis,0,sizeof(vis));
    queue <Coor> q;
    Coor t,k;

    vis[start]=1;
    t.x=start;
    t.step=0;

    q.push(t);

    while(!q.empty())
    {
        t=q.front();
        q.pop();

        if(t.x==finish) return t.step;

        k.x=t.x+1;
        if(judge(k.x))
        {
            k.step=t.step+1;
            vis[k.x]=1;
            q.push(k);
        }

        k.x=t.x-1;
        if(judge(k.x))
        {
            k.step=t.step+1;
            vis[k.x]=1;
            q.push(k);
        }

        k.x=t.x*2;
        if(judge(k.x))
        {
            k.step=t.step+1;
            vis[k.x]=1;
            q.push(k);
        }
    }
    return -1;
}

int main()
{
    int start;
    while(cin>>start>>finish)
    {
        cout<<bfs(start)<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Description The cow bicycling team consists of N (1 <= N <= 20) cyclists. They wish to determine a race strategy which will get one of them across the finish line as fast as possible. Like everyone else, cows race bicycles in packs because that's the most efficient way to beat the wind. While travelling at x laps/minute (x is always an integer), the head of the pack expends x*x energy/minute while the rest of pack drafts behind him using only x energy/minute. Switching leaders requires no time though can only happen after an integer number of minutes. Of course, cows can drop out of the race at any time. The cows have entered a race D (1 <= D <= 100) laps long. Each cow has the same initial energy, E (1 <= E <= 100). What is the fastest possible finishing time? Only one cow has to cross the line. The finish time is an integer. Overshooting the line during some minute is no different than barely reaching it at the beginning of the next minute (though the cow must have the energy left to cycle the entire minute). N, D, and E are integers. Input A single line with three integers: N, E, and D Output A single line with the integer that is the fastest possible finishing time for the fastest possible cow. Output 0 if the cows are not strong enough to finish the race. Sample Input 3 30 20 Sample Output 7 Hint as shown in this chart: leader E pack total used this time---leader--speed--dist---minute 1------1-------5------5------25 2------1-------2------7-------4 3------2*------4------11-----16 4------2-------2------13------4 5------3*------3------16------9 6------3-------2------18------4 7------3-------2------20------4 * = leader switch Source USACO 2002 February

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值