Cure HDU - 5879(预处理+技巧)

Cure

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4736    Accepted Submission(s): 1100


Problem Description
Given an integer n, we only want to know the sum of 1/k2 where k from 1 to n.
 
 
 
Input
There are multiple cases.
For each test case, there is a single line, containing a single positive integer n
The input file is at most 1M.
 
 
 
Output
The required sum, rounded to the fifth digits after the decimal point.
 
 
 
Sample Input
1 2 4 8 15
 
 
 
Sample Output
1.00000 1.25000 1.42361 1.52742 1.58044
 
 
 
Source
 
#include <iostream>
#include <cstdio>
#include <sstream>
#include <cstring>
#include <map>
#include <cctype>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#define rap(i, a, n) for(int i=a; i<=n; i++)
#define rep(i, a, n) for(int i=a; i<n; i++)
#define lap(i, a, n) for(int i=n; i>=a; i--)
#define lep(i, a, n) for(int i=n; i>a; i--)
#define rd(a) scanf("%d", &a)
#define rlld(a) scanf("%lld", &a)
#define rc(a) scanf("%c", &a)
#define rs(a) scanf("%s", a)
#define MOD 2018
#define LL long long
#define ULL unsigned long long
#define Pair pair<int, int>
#define mem(a, b) memset(a, b, sizeof(a))
#define _  ios_base::sync_with_stdio(0),cin.tie(0)
//freopen("1.txt", "r", stdin);
using namespace std;
const int maxn = 1000003, INF = 0x7fffffff;
double sum[maxn];
char str[maxn];

int main()
{
    sum[0] = 0.0;
    for(int i=1; i<maxn; i++)
        sum[i] = sum[i-1] + 1.0/((double)i*(double)i);

    int n;
    while(~rs(str))
    {
        n = 0;
        if(strlen(str) >= 7)
            printf("1.64493\n");
        else
        {
            int len = strlen(str);
            for(int i=0; i<len; i++)
                n = n * 10 + (str[i] - '0');
            printf("%.5f\n", sum[n]);
        }

    }

    return 0;
}

 

转载于:https://www.cnblogs.com/WTSRUVF/p/9509719.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值