Cure (打表)

Given an integer nn, we only want to know the sum of 1/k21/k2 where kk from 11 to nn.

Input

There are multiple cases. 
For each test case, there is a single line, containing a single positive integer nn. 
The input file is at most 1M. 

Output

The required sum, rounded to the fifth digits after the decimal point.

Sample Input

1
2
4
8
15

Sample Output

1.00000
1.25000
1.42361
1.52742
1.58044

这道题开始直接暴力,没暴力出来,那就是数据太大了

这里推算可知(百度)发现,当数据达到一定程度时,值就趋近于某一个固定的值,所以就当数据太大是直接输出,小的时候打表就行了

#include<iostream>
#include<cstring>
using namespace std;
const int N = 1e6+7;
double sum[N];
string str;
void init()
{
	sum[0]=0;
    for(int i = 1;i<=N;i++)
      sum[i]=sum[i-1]+double(1.0/i/i);//注意这里的强制转换
}
int main()
{
	init();
	while(cin >> str)
	{
        if(str.size()>=7)
			printf("%.5lf\n",sum[1000000]);
		else
		{
			int len = str.size();
			int n = 0;
			for(int i = 0;i<len;i++)
				n = n*10+str[i]-'0';
			printf("%.5lf\n",sum[n]);
		}
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值