粉丝要求,第一条博客。05-树9 Huffman Codes

05-树9 Huffman Codes

In 1953, David A. Huffman published his paper “A Method for the Construction of Minimum-Redundancy Codes”, and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string “aaaxuaxz”, we can observe that the frequencies of the characters ‘a’, ‘x’, ‘u’ and ‘z’ are 4, 2, 1 and 1, respectively. We may either encode the symbols as {‘a’=0, ‘x’=10, ‘u’=110, ‘z’=111}, or in another way as {‘a’=1, ‘x’=01, ‘u’=001, ‘z’=000}, both compress the string into 14 bits. Another set of code can be given as {‘a’=0, ‘x’=11, ‘u’=100, ‘z’=101}, but {‘a’=0, ‘x’=01, ‘u’=011, ‘z’=001} is NOT correct since “aaaxuaxz” and “aazuaxax” can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.
Input Specification:
Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤63), then followed by a line that contains all the N distinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] ... c[N] f[N]

where c[i] is a character chosen from {‘0’ - ‘9’, ‘a’ - ‘z’, ‘A’ - ‘Z’, ‘_’}, and f[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer M (≤1000), then followed by M student submissions. Each student submission consists of N lines, each in the format:

c[i] code[i]

where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 '0’s and '1’s.
Output Specification:
For each test case, print in each line either “Yes” if the student’s submission is correct, or “No” if not.
Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.
Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11

Sample Output:

Yes
Yes
No
No

题意解析:一开始题目先稍微讲述了一下哈夫曼树和编码的历史。本题在一开始题目给出整数n和n个字符以及字符出现的频率。接下来给出整数m,即m个测试样例,需要你对每个编码样例进行判断,如果是最有编码 输出Yes,不是输出No。
是否是最优编码只需要考虑两个方面,即根据字符出现频率生成的哈夫曼树的WPL和所有字符编码长度与其出现频率之积的和相等,以及是否存在前缀编码的情况。
C++STL中提高的容器priority_queue优先队列可以很好的模拟哈夫曼树WPL的计算,代码是利用priority_queue计算的WPL,需要了解更多priority_queue可以自行查阅资料。废话不多少上代码

#include <bits/stdc++.h>
#define maxn 128
using namespace std;

priority_queue<int, vector<int>, greater<int>> q;//优先队列从小到大排序
map<char, int> mp;//利用STL自带容器map映射,来存储字符和频率的关系

struct Node{
	char ch;
	int qre;
}N[maxn];

struct HuffCode{
	char ch;
	string Code;
}C[maxn];

int BulidTree(int n,struct Node N[])//计算WPL值
{
	int weight = 0;
	for (int i = 0; i < n; i++)
	q.push(N[i].qre);//将所有字符频率入队列
	while (q.size() > 1)//每次将两个最小的出队列,再把他们之和入队列
	{
		int x, y;
		x = q.top();
		q.pop();
		y = q.top();
		q.pop();
		weight += x + y;
		q.push(x + y);
	}
	q.pop();
	return weight;
}

bool cmp(HuffCode a, HuffCode b)
{
	return a.Code.size() < b.Code.size();//重构cmp函数
}

bool isPrefix(int n, HuffCode C[])//判断是否存在前缀编码
{
	sort(C, C + n, cmp);
	for (int i = 0; i < n; i++)
	{
		string str = C[i].Code;
		for (int j = i + 1; j < n; j++)
		{
			string str2 = C[j].Code.substr(0, C[i].Code.size());
			if (str == str2)
			return true;
		}
	}
	return false;
}

void judge(int n, int weight)
{
	int colden = 0;
	for (int i = 0; i < n; i++)
	{
		cin>>C[i].ch>>C[i].Code;
		colden += C[i].Code.size() * mp[C[i].ch];
	}
	if (isPrefix(n, C) || weight != colden)
	cout<<"No"<<endl;
	else
	cout<<"Yes"<<endl;
}
int main()
{
	int n, m;
	int weight;
	cin>>n;
	cin.get();
	for (int i = 0; i < n; i++)
	{
			cin>>N[i].ch>>N[i].qre;
			mp[N[i].ch] = N[i].qre;
	}
	weight = BulidTree(n, N);
	cin>>m;
	cin.get();
	for (int i = 0; i < m; i++)
	{
		judge(n, weight);
	}		
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值