Has the sum exceeded

Has the sum exceeded

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3671    Accepted Submission(s): 779


Problem Description
As we all know, in the computer science, an integer A is in the range of 32-signed integer, which means the integer A is between -2^31 and (2^31)-1 (inclusive), and A is a 64-signed integer, which means A is between -2^63 and (2^63)-1(inclusive). Now we give the K-signed range, and two K-signed integers A and B, you should check whether the sum of A and B is beyond the range of K-signed integer or not.
 

Input
There will be many cases to calculate. In each case, there comes the integer K (2<=K<=64) first in a single line. Then following the line, there is another single line which has two K-signed integers A and B.
 

Output
For each case, you should estimate whether the sum is beyond the range. If exceeded, print “Yes”, otherwise “WaHaHa”.
 

Sample Input
  
  
32 100 100
 

Sample Output
  
  
WaHaHa
 

Author
Wangye
 

#include <stdio.h>
#include <math.h>
int main()
{
	int base;
	__int64 a,b,sum,c[64],d[64],e=0,f=-1;
	for (int i=0;i<64;i++)
	{
		c[i]=e;
		d[i]=f;
		e=e*2+1;
		f=f*2;
	}//这个就相当于pow函数,可能是pow函数有问题,随意改成连乘进行计算!
	while(scanf("%d",&base)!=EOF)
	{
		scanf("%I64d%I64d",&a,&b);
		sum=a+b;
        if (base==64)//因为整数的最高位为64位,所以会出现溢出错误,这一点要切记!
        {
			if (a>0&&b<0||a<0&&b>0)
			{
				printf("WaHaHa\n");
			}
			else if ((a>0&&b>0)&&sum<=0)
			{
				printf("Yes\n");
			}
			else if ((a<0&&b<0)&&sum>=0)
			{
                printf("Yes\n");
			}
			else//因为上面的条件不全,所以最后务必打上else
			{
				printf("WaHaHa\n");
			}//上面为判断64位的溢出错误!
        }
		else
		{
			if (sum>=d[base-1]&&sum<=c[base-1])
			{
				printf("WaHaHa\n");
			}
			else
			{
				printf("Yes\n");
			}
		}
	}
	
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值