杭电2116Has the sum exceeded

Has the sum exceeded

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4030    Accepted Submission(s): 849


Problem Description
As we all know, in the computer science, an integer A is in the range of 32-signed integer, which means the integer A is between -2^31 and (2^31)-1 (inclusive), and A is a 64-signed integer, which means A is between -2^63 and (2^63)-1(inclusive). Now we give the K-signed range, and two K-signed integers A and B, you should check whether the sum of A and B is beyond the range of K-signed integer or not.
 

Input
There will be many cases to calculate. In each case, there comes the integer K (2<=K<=64) first in a single line. Then following the line, there is another single line which has two K-signed integers A and B.
 

Output
For each case, you should estimate whether the sum is beyond the range. If exceeded, print “Yes”, otherwise “WaHaHa”.
 

Sample Input
32
100 100
 

Sample Output
WaHaHa
 

Author
Wangye
 

Source
HDU 2007-10 Programming Contest_WarmUp
 
不算难题,考虑一下溢出的情况,加法溢出就减法,减法溢出
附代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
__int64 a,b,m,n,Max,Min;
void ac(int n)
{
	__int64 ans=1;
	for(int i=1;i<n;i++)
	ans*=2;
	Min=-ans;
	Max=ans-1;
}
int main()
{
	while(scanf("%I64d%I64d%I64d",&n,&a,&b)!=EOF)
	{
		ac(n);
		//printf("%I64d %I64d\n",Max,Min);
			if((a>=0&&b<=0)||(a<=0&&b>=0))
			printf("WaHaHa\n");
			if(a>0&&b>0)
			{
			if(a>Max-b)
			printf("Yes\n");
			else
			printf("WaHaHa\n");
			}
			if(a<0&&b<0)
			{
			if(a<Min-b)
			printf("Yes\n");
			else
			printf("WaHaHa\n");	
			}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值