HDOJ2116 Has the sum exceeded

Has the sum exceeded

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4869    Accepted Submission(s): 1093


Problem Description
As we all know, in the computer science, an integer A is in the range of 32-signed integer, which means the integer A is between -2^31 and (2^31)-1 (inclusive), and A is a 64-signed integer, which means A is between -2^63 and (2^63)-1(inclusive). Now we give the K-signed range, and two K-signed integers A and B, you should check whether the sum of A and B is beyond the range of K-signed integer or not.
 

Input
There will be many cases to calculate. In each case, there comes the integer K (2<=K<=64) first in a single line. Then following the line, there is another single line which has two K-signed integers A and B.
 

Output
For each case, you should estimate whether the sum is beyond the range. If exceeded, print “Yes”, otherwise “WaHaHa”.
 

Sample Input
  
  
32 100 100
 

Sample Output
  
  
WaHaHa
 
判断A+B的和是否在(-2^(k-1),2^k  -1)范围里
需要打表,并且使用大数来做
import java.math.BigInteger;
import java.util.Scanner;

public class Main{
	private static Scanner scanner;
	private static long arr[];

	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		function() ;
		while (scanner.hasNext()) {
			int n = scanner.nextInt();
			String aString = scanner.next();
			String bString = scanner.next();
			BigInteger aInteger = new BigInteger(aString);
			BigInteger bInteger = new BigInteger(bString);
			aInteger = aInteger.add(bInteger);// 和
			
			BigInteger maxInteger = new BigInteger("" + (arr[n] - 1));// 范围的最大值
			BigInteger minInteger = new BigInteger("" + (-arr[n]));// 范围的最小值
			if (aInteger.compareTo(maxInteger) > 0 || aInteger.compareTo(minInteger) < 0) {
				System.out.println("Yes");
			} else {
				System.out.println("WaHaHa");
			}
		}
	}

	public static void function() {
		arr = new long[65];
		arr[1] = 1;
		for (int i = 2; i <= 64; i++) {
			arr[i] = arr[i - 1] * 2;
		}
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值