Largest Rectangle in a Histogram(动态规划找最大矩形面积)

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13480    Accepted Submission(s): 3817


Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
  
  
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 

Sample Output
  
  
8 4000
 

Source
 
这个题特别有意思!就是给你若干个高度不一的正方形,让你找

出这里面面积最大的长方形!

这一题用到了动态规划,原理是这样的!每一个图形都有一个

h[i],l[i],r[i]!其中l[i]存的是左数至少比他高的图形的序数,r[i]存

的是右数至少比他高的图形的序数!这一题数目庞大!所以这一

点 while(h[r[i]+1]>=h[i]) {r[i]=r[r[i]+1];}特别重要!看右面有没

有比他大的,有就看右面那个r[]存的序数是多少,一步一步最

终找到连续的长方形!
#include<cstdio>
#include<iostream>
const int N=110000;
using namespace std;
long long h[N],l[N],r[N];
int main()
{
    long long n;
    int i;
    while(scanf("%lld",&n)&&n)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%lld",&h[i]);
            l[i]=r[i]=i;
        }
        h[0]=h[n+1]=-1;
        for(i=1;i<=n;i++)
        {
            while(h[l[i]-1]>=h[i])
            {
                l[i]=l[l[i]-1];//这个体现动态规划的思想,存l[l[i]-1]而不是l[i]-1
            }//这样就可以节省其中很多的步骤!根据动态规划原理这一找
        }
        for(i=n;i>=1;i--)
        {
            while(h[r[i]+1]>=h[i])
            {
                r[i]=r[r[i]+1];
            }
        }
        long long maxs=-5,flag;
        for(i=1;i<=n;i++)
        {
           flag=(r[i]-l[i]+1)*h[i];
           if(flag>maxs)
           {
               maxs=flag;
           }
        }
       printf("%lld\n",maxs);
    }
}



  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值