Repository(字典树,避免重复计数)

Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2865    Accepted Submission(s): 1096


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
  
  
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
  
  
0 20 11 11 2
 

Source
 

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
struct Tree
{
    int num;
    int flag;
    Tree *next[26];
    Tree()
    {
        num=0;
        for(int i=0;i<26;i++)
        {
            next[i]=NULL;
        }
    }
}*root;//建树!
void insert(Tree *p,char *s,int n)
{
    int i=0;
    while(s[i])
    {
        int x=s[i]-'a';
        if(p->next[x]==NULL)
        {
            p->next[x]=new Tree();
        }//如果没有就新建一个!
        p=p->next[x];
        if(p->flag!=n)//看他的记录如果不是n
        {
            p->flag=n;//标记新的flag
            p->num++;//数字加一!
        }//重复就算一个!
        i++;
    }
}
int find(Tree *p,char *s)
{
    int ans,i=0;
    while(s[i])
    {
        int n=s[i]-'a';
        if(p->next[n]==NULL)
        {
            return 0;
        }//不重复就0
        else
        {
            p=p->next[n];
            ans=p->num;
        }
        i++;
    }
    return ans;
}
int main()
{
    int n,m,stl,i,j;
    char s[30];
    root=new Tree();
    cin>>n;
    for(i=1;i<=n;i++)
    {
       cin>>s;
        stl=strlen(s);
        for(j=0;j<stl;j++)
        {
            insert(root,s+j,i);
        }
    }
 //   cout<<"   ok"<<endl;
    cin>>m;
    while(m--)
    {
       cin>>s;
        cout<<find(root,s)<<endl;
    }
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值