Repository

When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
Sample Input
20
ad
ae
af
ag
ah
ai
aj
ak
al
ads
add
ade
adf
adg
adh
adi
adj
adk
adl
aes
5
b
a
d
ad
s
Sample Output
0
20
11
11

2

题目意思:输入一些商品名称,然后再输入要查询的单词,看这些商品名称有多少个含有这些单词。

解题思路:想了半天也没想到什么好的办法,看了别人的题解报告才知道的。这道题在建树时不能直接把

商品名称用来建树,而是把商品名称的所有后缀用来建树,比如商品名asdf,那么我们就应该

依次把asdf,sdf,df,f进行建树,然后用一个计数器,记录这个单词有多少个,还需要有一

个标记,记录该后缀是否已被记录过,若是就不记录。

#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;


struct trie{
	
	int v;
	int m;    //是否重复; 
	trie *next[26];
	trie(){
		v=0;
		for(int i=0;i<26;i++)
		{
			m=-1;
			v=0; 
			next[i]=NULL;
		}
	}
}; 

trie *root;

void creat(trie *root,char *str,int k)
{
	trie *p=root;
	for(;*str;str++)
	{
		int sign=*str-'a';
		if(p->next[sign]==NULL)
		{
			p->next[sign]=new trie();
		}
		p=p->next[sign];
		if(p->m!=k)
		{
			p->m=k;
			p->v++;			
		}
	}
}

int find(trie *root,char *str)
{
	int len=strlen(str);
	trie *p=root;
	for(int i=0;i<len;i++)
	{
		int id=str[i]-'a';
		if(p->next[id]==NULL)
		{
			return 0;
		}
		p=p->next[id];
	}
	return p->v;
}

void del(trie *root)
{
	for(int i=0;i<26;i++)
	{
		if(root->next[i])
		{
			del(root->next[i]); 
		}
	}
	delete(root);
}

int main()
{
	int n,m;
	char s[30];
	root=new trie();
	cin>>n;
	while(n--)
	{
		scanf("%s",s);
		for(int j=0;j<strlen(s);j++)
		{
			creat(root,s+j,n);
		}
	}
	cin>>m;
	while(m--)
	{
		scanf("%s",s);
		cout<<find(root,s)<<endl;
		
	}
	del(root);
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值