Jerry Lee’s Stones(动态规划(最长不重复子串)+Hash)

1240: Jerry Lee’s Stones

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 48   Solved: 3
[ Submit][ Status][ Web Board]

Description

Jerry Lee the entrepreneur has a cool business idea: packaging stones as gifts. He has devised a machine that captures stones, and serializes them into a stream of stones that pass, one by one, into a package. Once the package is full, it is closed and shipped to be sent.

The marketing motto for the company is "bags of uniqueness." To live up to the motto, every stone in a package must be different from the others. Unfortunately, this is easier said than done, because in reality, many of the stones passing through the machine are identical. Jerry Lee would like to know the size of the largest possible package of unique stones that can be created. The machine can start filling the package at any time, but once it starts, all stones passing from the machine must go into the package until the package is completed and sealed.

Input

The first line of input contains one integer specifying the number of test cases to follow. Each test case begins with a line containing an integer n, the number of stones processed by the machine. The following n lines each contain an integer (in the range 0 to 10^9, inclusive) uniquely identifying a stone. Two stones are identified by the same integer if and only if they are identical. The input will contain no more than one million total stones.

Output

For each test case output a line containing single integer, the maximum number of unique stones that can be in a package.

Sample Input

1
5
1
2
3
2
1

Sample Output

3

HINT

Source

这一题考的是最长不重复子串!

#include <iostream>
#include <cstdio>
#include<vector>
#include <cstring>
const int N=10000000;
using namespace std;
int myHash[N];
int vec[N];
int solve(int *vec,int n)
{
    int lastpos,global,local;
    lastpos=global=local=0;
    memset(myHash, 0, sizeof(myHash));
    for(int i = 0; i <n; i ++)
    {
         int key = vec[i]-0;
         myHash[key] ++;
         if(myHash[key] == 2)
         {
            global = max(global, local);
            for(; lastpos < i && vec[lastpos] != vec[i]; lastpos++)
            {
                myHash[vec[lastpos]-0]--;
            }
            local = i - lastpos;
            myHash[key]--;
            lastpos++;
         }
         else
         {
            local ++;
         }
    }
    global = max(global, local);
    return global;
}
int main()
{
    int t,n,i,a;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(i=0;i<n;i++)
        {
            cin>>vec[i];
        }
        cout<<solve(vec,n)<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值