HDU1227 Fast Food(DP)

Description
The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.

To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built.

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as must be as small as possible.
Write a program that computes the positions of the k depots, such that the total distance sum is minimized.

Input
The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly.
The input file will end with a case starting with n = k = 0. This case should not be processed.

Output
For each chain, first output the number of the chain. Then output a line containing the total distance sum.
Output a blank line after each test case.

Sample Input
6 3
5
6
12
19
20
27
0 0

Sample Output
Chain 1

Total distance sum = 8


题意:给你n个饭店的坐标,要求选择其中的m个饭店为原料供应地,求这n个饭店到达离自己最近的原料供应地的距离和。


思路:dp[i][j]表示在1-i个饭店建立j个原料供应地且第i个一定为原料供应地时,前i个饭店的最短距离和。

首先预处理出,dp[i][1],即仅在i处建立一个原料供应地时前i个饭店的最短距离和。

如果我们已知dp[2][1]、dp[1][1],那么dp[3][2]=min{dp[2][1]+d[2][3], dp[1][1]+d[1][3]}

d[i][j]表示当i.j之间没有原料地,只有i.j两处有时,i-j之间饭店的最短距离和。

由此推出dp[i][j]=min{dp[i][j],dp[k][j-1]+d[k][i]}   


不得不说我还是太菜了= =。知道了转移方程以后还是因为三重循环的顺序分析了很久。因为是先确定仅确定一个原料地的dp值,然后确定两个的,以此类推。所以第一重循环应该是j=1~m。因为建立了j个原料地,所以i=j~n。枚举的k已经建立了j-1个原料地,且又要位于i前面,所以k=j-1~i-1。


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <math.h>
#include <map>
using namespace std;

int a[205];
int d[205][205];
int dp[205][40];

int main()
{
    int n,m;
    int T=1;
    while(scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0) break;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        memset(d,0,sizeof(d));
        for(int i=1;i<=n;i++)
        {
            for(int j=i;j<=n;j++)
            {
                for(int k=i;k<=j;k++)
                {
                    d[i][j]+=min(a[k]-a[i],a[j]-a[k]);
                }
            }
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=i;j++)
            {
                dp[i][1]+=a[i]-a[j];
            }
        }
        for(int j=2;j<=m;j++)
        {
            for(int i=j;i<=n;i++)
            {
                dp[i][j]=0x3f3f3f3f;
                for(int k=j-1;k<i;k++)
                {
                    dp[i][j]=min(dp[i][j],dp[k][j-1]+d[k][i]);
                }
            }
        }
        printf("Chain %d\n",T++);
        printf("Total distance sum = ");
        int ans=dp[n][m];
        for(int i=1;i<=n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                dp[i][m]+=a[j]-a[i];
            }
            ans=min(ans,dp[i][m]);
        }
        printf("%d\n\n",ans);
    }
    return 0;
}

经常搞不清循环的先后,还有正序还是逆序,这是药丸- -。关键是要搞清楚谁是谁的前提- -。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值