Fast Food - UVa 662 dp

Fast Food

The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurent and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.


To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers $d_1 < d_2 < \dots < d_n$ (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number$k (k \leŸ n)$ will be given, the number of depots to be built.

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as


\begin{displaymath}\sum_{i=1}^n \mid d_i - (\mbox{position of depot serving restaurant }i) \mid\end{displaymath}

must be as small as possible.

Write a program that computes the positions of the k depots, such that the total distance sum is minimized.

Input 

The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers  n  and  k n  and  k  will satisfy  $1 \leŸ n\leŸ 200$ $1 \leŸ k Ÿ\le 30$ $k \le n$ . Following this will  n  lines containing one integer each, giving the positions  d i  of the restaurants, ordered increasingly.

The input file will end with a case starting with n = k = 0. This case should not be processed.

Output 

For each chain, first output the number of the chain. Then output an optimal placement of the depots as follows: for each depot output a line containing its position and the range of restaurants it serves. If there is more than one optimal solution, output any of them. After the depot descriptions output a line containing the total distance sum, as defined in the problem text.


Output a blank line after each test case.

Sample Input 

6 3
5
6
12
19
20
27
0 0

Sample Output 

Chain 1
Depot 1 at restaurant 2 serves restaurants 1 to 3
Depot 2 at restaurant 4 serves restaurants 4 to 5
Depot 3 at restaurant 6 serves restaurant 6
Total distance sum = 8

题意:在n个餐厅里设立m个为仓库,使得每个餐厅到最近的仓库的距离和最小。

思路:先求出sum[i][j]为i到j的餐厅之间如果设立一个仓库的距离最小和,sum[i][j]=sum[i][j-1]+num[j]-num[(i+j)/2];因为仓库设在中间肯定是距离最小的,偶数个的话,中间的两个是一样的。然后遍历k使得dp[i][j]=min(dp[i][j],dp[k][j-1]+sum[k+1][i]);表示到i个餐厅设立j个仓库的最短距离。然后输出路径。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int sum[210][210],dp[210][40],num[210],pos[40];
int main()
{ int t=0,n,m,k,i,j,l,r;
  while(~scanf("%d%d",&n,&m) && n+m)
  { for(i=1;i<=n;i++)
     scanf("%d",&num[i]);
    for(i=1;i<=n;i++)
     for(j=i+1;j<=n;j++)
      sum[i][j]=sum[i][j-1]+num[j]-num[(i+j)/2];
    for(i=1;i<=n;i++)
    { dp[i][1]=sum[1][i];
      for(j=2;j<=m;j++)
       { dp[i][j]=dp[1][j-1]+sum[2][i];
         for(k=2;k<i;k++)
          dp[i][j]=min(dp[i][j],dp[k][j-1]+sum[k+1][i]);
       }
    }
    l=n;
    for(j=m;j>=1;j--)
    { for(k=0;k<=l;k++)
       if(dp[l][j]==dp[k][j-1]+sum[k+1][l])
       { pos[j]=k+1;
         l=k;
         break;
       }
    }
    pos[m+1]=n+1;
    printf("Chain %d\n",++t);
    for(i=1;i<=m;i++)
    { l=pos[i];r=pos[i+1]-1;
      if(r-l>0)
       printf("Depot %d at restaurant %d serves restaurants %d to %d\n",i,(l+r)/2,l,r);
      else
       printf("Depot %d at restaurant %d serves restaurant %d\n",i,l,l);
    }
    printf("Total distance sum = %d\n\n",dp[n][m]);
  }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值