HDU 4405 Aeroplane chess(概率DP)

Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N. 

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid. 

Please help Hzz calculate the expected dice throwing times to finish the game.


Input
There are multiple test cases. 
Each test case contains several lines. 
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000). 
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N). 

The input end with N=0, M=0.


Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point. 
Sample Input
2 0
8 3
2 4
4 5
7 8

0 0


Sample Output
1.1667

2.3441


题意:一排格子标号0-N,从0要到达N。扔骰子决定每次步数。M对格子x,y,表示当到达x时可以直接跳到y。问到达N时扔骰子的次数期望。

思路:

1.先开始想复杂了,考虑了并查集什么鬼的MDZZ,我果然还是太菜了

2.对于一对x,y,pre[x]=y,这样直接赋值dp[x]=dp[pre[x]]就行了。

3.如果对于一个i,pre[i]=-1表示他不能直接跳到某一格,那么他的期望次数,就是他后面1-6格的期望次数+1(因为多扔了一次骰子)*p。骰子的数字概率相同,p=1/6。

4.初始状态为dp[n],此时已经在n上了,所以不需要再扔骰子,次数期望为0。需要求的是dp[0],即在0上时要到n上的次数期望。


#include <cstring>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <algorithm>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
using namespace std;

double dp[100005];
int pre[100005];

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0) break;
        memset(pre,-1,sizeof(pre));
        for(int i=0;i<m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            pre[x]=y;
        }
        memset(dp,0,sizeof(dp));
        for(int i=n-1;i>=0;i--)
        {
            if(pre[i]==-1)
            {
                for(int j=1;j<=6;j++)
                {
                    dp[i]+=(dp[i+j]+1)/6.0;
                }
            }
            else dp[i]=dp[pre[i]];
        }
        printf("%.4lf\n",dp[0]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值