HDU_2298_Toxophily

6 篇文章 0 订阅
4 篇文章 0 订阅

Toxophily

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1480    Accepted Submission(s): 772


Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m.
 


Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.
Technical Specification

1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000.
 


Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output "-1", if there's no possible answer.

Please use radian as unit.
 


Sample Input
  
  
3 0.222018 23.901887 121.909183 39.096669 110.210922 20.270030 138.355025 2028.716904 25.079551
 


Sample Output
  
  
1.561582 -1 -1
 


Source
 


Recommend
lcy


这个题目归类是个三分法的题目

就是个抛物线过点的问题

不过说实话三分法还真不知道怎么做

直接当做一道物理题做了……

//角度sita
//x=v*cos(sita)*t
//y=v*sin(sita)*t-1/2*g*t*t
//1/2*g*x*x*tan(sita)*tan(sita)-x*v*v*tan(sita)+y*v*v+1/2*g*x*x=0这里用了1/cos=scs 1+tan^2=scs^2
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
const double AC=1e-8;
const double PI=acos(-1.0);
const double g=9.8;

int main()
{
    int t;
    double x,y,v,sita1,sita2,tsi1,tsi2;
    double a,b,c,deta;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf",&x,&y,&v);
        a=g*x*x;
        b=-2*x*v*v;
        c=2*y*v*v+g*x*x;
        deta=b*b-4*a*c;
        if(deta<0)
        {
            printf("-1\n");
            continue;
        }
        deta=sqrt(deta);
        tsi1=(-b-deta)/(2*a);
        tsi2=(-b+deta)/(2*a);
        sita1=min(atan(tsi1),atan(tsi2));
        sita2=max(atan(tsi1),atan(tsi2));
        if(sita1>=0&&sita1<=PI/2.0)
            printf("%.6lf\n",sita1);
        else if(sita2>=0&&sita2<=PI/2.0)
            printf("%.6lf\n",sita2);
        else
            printf("-1\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值