LA_3026_HDU_1358_Period

21 篇文章 0 订阅
8 篇文章 0 订阅

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5363    Accepted Submission(s): 2582


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
  
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
  
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 

Recommend
JGShining


这个题目问一个串的前缀,如果可以写成一个串重复2次以上

那么输出这个前缀的长度和重复次数

枚举串匹配好像并不能过这个题目的数据

这个题目其实要对KMP的next数组有一定的理解

abcabcabc这样的串会在next数组形成怎样的形式其实是解决这个题目的关键

应该说KMP形成这样功能的next数组是必然的,而不是偶然的

是考虑到了尽量减少重复部分再比较的结果

可以输出中间的next来看一下

#include <iostream>
#include <stdio.h>
using namespace std;

const int MN=1e6+5;
char s1[MN];
int nex[MN];

void getnext(int m)
{
    int j=0,k=-1;
    nex[0]=-1;
    while(j<m)
    {
        if(k==-1||s1[k]==s1[j])
            nex[++j]=++k;
        else
            k=nex[k];
    }
}

int main()
{
    int n;
    int ca=1;
    while(1)
    {
        scanf("%d",&n);
        if(!n)
            break;
        scanf("%s",s1);
        getnext(n);
        //for(int i=0;i<=n;i++)
        //    cout<<nex[i]<<" ";
        //cout<<endl;
        printf("Test case #%d\n",ca++);
        for(int i=2;i<=n;i++)
            if(nex[i]>0&&i%(i-nex[i])==0)//当出现返回不返回开头的时候其实就是出现了重复,整除说明存在循环
                printf("%d %d\n",i,i/(i-nex[i]));
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值