HDU - 1358 Period

Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

[]   [Go Back]   [Status]  

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) � the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input

    
    
3 aaa 12 aabaabaabaab 0
 

Sample Output

    
    
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 

Source






kmp求周期,简单题:

//本题的输入排除了周期i/k=1的情况
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1000000+10;
int next[maxn];
char s[maxn];
int n;
void getnext(char *s)//kmp不仅出现在kmp函数,在其他函数也都用到了kmp
{
    int j=-1,i=0;
    next[0]=-1;
    while(i<n)
    {
        if(j==-1||s[i]==s[j])
        {
            i++,j++;
            next[i]=j;//next[i]表示i位置的上一个位置(即i-1位置)的部分匹配值
        }
        //else j=-1;//还是这句简洁高效,错!
        else j=next[j];//为了防止出错,用这句更保险(需要字符串自身匹配,只能用这句,不能用楼上)
    }
}


int main()
{
    int i,t=0;
    while(scanf("%d",&n)&&n!=0)
    {
        t++;
        scanf("%s",s);
        getnext(s);
        printf("Test case #%d\n",t);
        if(n==2) printf("2 2\n\n");//严格按照题意,这里要加上这句话,否则当n=2,只输出Test case #t。而题意是允许n=2的。但本题不写这句也可以AC
        else
        {
                for(i=2;i<=n;i++)
            {
                int k=i-next[i];//题目要求周期i/k>1
                if(i/k>1&&i%k==0) printf("%d %d\n",i,i/k);
            }
            printf("\n");
        }
    }
    return 0;
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值