HDU_2955_Robberies(变种的01背包)

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20340    Accepted Submission(s): 7529


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6
 

Source
 

Recommend
gaojie

题意

有一个抢银行的家伙

给出抢某个银行被抓的概率和收益

现在问不被抓的情况下最多可以拿到多少钱


解题思路

这个题目如果不是在背包的题目列表下可能真的想不到是背包

这个题目要想清楚就是

1在有AB两个银行时,抢某个银行被抓的概率的计算假设A为pA,B为pB

则p被抓=pA+(1-pA)*pB=pB+(1-pB)*pA

因此这个关系是比较复杂的,可以做一个转化,不被抓的概率

则p不被抓=(1-pA)*(1-pB) 故对输入全部用1减下

2就是这题目要对钱当做体积,求一个当前钱数的不被抓概率

之后就是01背包的过程不再做加法而是乘法了。

3初始状态dp[0]=1;显然的不抢是绝对安全的


#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

const int M=10005;
double dp[M];
double wi[M];
int vi[M];

int main()
{
    int t;
    scanf("%d",&t);
    int n,v;
    double p;
    while(t--)
    {
        scanf("%lf%d",&p,&n);
        v=0;
        p=1-p;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%lf",&vi[i],&wi[i]);
            wi[i]=1-wi[i];
            v+=vi[i];
        }
        //cout<<"v "<<v<<endl;
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=1;i<=n;i++)
        {
            for(int j=v;j>=vi[i];j--)
                dp[j]=max(dp[j],dp[j-vi[i]]*wi[i]);
        }
        int ans=0;
        //cout<<"v "<<v<<endl;
        for(int i=v;i>=0;i--)
            if(dp[i]>p)
            {
                ans=i;
                //cout<<ans<<endl;
                break;
            }
        printf("%d\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值