poj_1068_Parencodings

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
 S		(((()()())))

 P-sequence	    4 5 6666 
 W-sequence	    1 1 1456 

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

模拟题,思路是把第一个序列转换成相应的括号字符串,然后从第一个‘)’开始找离它最近而且没有被标记过的左括号

#include <iostream>
#include <stdio.h>
#include <string.h>


using namespace std;
int a[22];
char str[44];
bool vis[44]={0};


int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d",&n);
        a[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        int ct=1;
        for(int j=1;j<=n;j++)
        {
            m=a[j]-a[j-1];
            for(int p=1;p<=m;p++)
            {
                str[ct++]='(';
            }
            str[ct++]=')';
        }
        ct--;
        //cout<<"ct:"<<ct<<endl;
        //for(int i=1;i<=ct;i++) printf("%c",str[i]);
        //cout<<endl;
        int f=0,ans=0,i;
        for( i=1;i<=ct;i++)
        {
            if(str[i]==')')
            {
                f=i;
                for(int j=f-1;j>0;j--)
                {
                    if(str[j]=='('&&!vis[j])
                       {
                           vis[j]=1;
                           ans++;
                           printf("%d ",ans);
                           ans=0;
                           break;
                       }
                    else if(str[j]=='('&&vis[j])
                        {
                            ans++;
                        }
                }
                i=f;
            }
        }
        printf("\n");
        memset(vis,0,sizeof(vis));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值