hdu oj 2639 Bone Collector II (01背包k优解)

hdu oj 2639 Bone Collector II 

题目:

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3039    Accepted Submission(s): 1575


Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
12 2 0
 

解析:

  • 基础:01背包,归并排序(01背包教程点此归并排序教程点此
  • 本题的基本思路就是当前 i 个物品的k优价值时第 i+1 个物品放与不放的的总价值记下来,最后将所有的价值进行排序。

代码:

#include<stdio.h>
#include<string.h>
int c[101],w[101],dp[10005][40],a[40],b[40];
int main()
{
    int t,i,j,h,n,v,k,x,y,z;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d %d",&n,&v,&k);
        for(i=0;i<n;i++)
            scanf("%d",&w[i]);
        for(i=0;i<n;i++)
            scanf("%d",&c[i]);
        memset(dp,0,sizeof(dp));//初始化dp数组
        for(i=1;i<=n;i++)
        {
            for(j=v;j>=c[i];j--)
            {
                for(h=1;h<=k;h++)//k优解的k优解
                {
                    a[h]=dp[j-c[i]][h]+w[i];//分别求出放与不放的价值
                    b[h]=dp[j][h];
                }
                a[h]=b[h]=-1;
                x=y=z=1;
                while(z<=k && (a[x]!=-1||b[y]!=-1))//将得到的所有的价值进行归并排序。将两个数组排序
                {
                    if(a[x]<b[y])
                        dp[j][z]=b[y++];
                    else
                        dp[j][z]=a[x++];
                    if(dp[j][z]!=dp[j][z-1])//判断和上一个是否相同
                        z++;
                }
            }
        }
        printf("%d\n",dp[v][k]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值