hdu 5543 Pick The Sticks(01背包)

Pick The Sticks

Time Limit: 15000/10000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2204    Accepted Submission(s): 720


Problem Description
The story happened long long ago. One day, Cao Cao made a special order called "Chicken Rib" to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.

Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he's clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.

He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.

Formally, we can treat the container stick as an  L  length segment. And the gold sticks as segments too. There were many gold sticks with different length  ai  and value  vi . Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.

As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.

Can you help solve the mystery by finding out what's the maximum value of the gold sticks Xiu Yang could have taken?
 

Input
The first line of the input gives the number of test cases,  T(1T100) T  test cases follow. Each test case start with two integers,  N(1N1000)  and  L(1L2000) , represents the number of gold sticks and the length of the container stick.  N  lines follow. Each line consist of two integers,  ai(1ai2000)  and  vi(1vi109) , represents the length and the value of the  ith  gold stick.
 

Output
For each test case, output one line containing  Case #x: y, where  x  is the test case number (starting from 1) and  y  is the maximum value of the gold sticks Xiu Yang could have taken.
 

Sample Input
  
  
4 3 7 4 1 2 1 8 1 3 7 4 2 2 1 8 4 3 5 4 1 2 2 8 9 1 1 10 3
 

Sample Output
  
  
Case #1: 2 Case #2: 6 Case #3: 11 Case #4: 3
Hint
In the third case, assume the container is lay on x-axis from 0 to 5. Xiu Yang could put the second gold stick center at 0 and put the third gold stick center at 5, so none of them will drop and he can get total 2+9=11 value. In the fourth case, Xiu Yang could just put the only gold stick center on any position of [0,1], and he can get the value of 3.



///Pick The Sticks (01背包)
///题目大意:给你一根长为m的长木板和一些小木棒,每一根小木棒有它的长度和价值,这些小木棒要放在
///长木板上,并且每一根小木棒的重新放在长木板上(即可以露出一半的长),问最大价值是多少
///dp[i][j][k] 表示前i个小棒放到长度为j的木板上,其中k个小木棒放在边沿部分,边沿部分的小棒需要
///尽量放在木板外面(贪心思维),所以放在边沿的木棒落在木板上的长度为l/2. 然后就是简单的01背包问题
///tip:放一个小木棒的情况需要预处理,因为不管木板长度为多少,一个小棒总是能平衡的
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stdio.h>
#define cle(n) memset(n,0,sizeof(n))
using namespace std;
const int maxn =1010;
const int maxl =4010;
const int mod= 1000000007;
typedef long long ll;
ll dp[maxl][3];
int len[maxn],cost[maxn];

int main()
{
    int cnt=0,n,l,ca=1,T;
    scanf("%d",&T);
    while(T--)
    {
        cle(dp);
        ll ans=0;
        scanf("%d %d",&n,&l);
        l*=2;
        for(int i=0;i<n;i++)
        {
            scanf("%d %d",len+i,cost+i);
            len[i]*=2;
            ans=max(ans,(ll)cost[i]);
        }

        for(int i=0;i<n;i++)
        {
            for(int j=l;j>=len[i]/2;--j)
            {
                for(int k=0;k<3;k++)
                {
                    if(j>=len[i])
                        dp[j][k]=max(dp[j][k],dp[j-len[i]][k]+cost[i]);
                    if(k>0)
                        dp[j][k]=max(dp[j][k],dp[j-len[i]/2][k-1]+cost[i]);
                    ans=max(ans,dp[j][k]);
                }
            }
        }
        printf("Case #%d: %lld\n", ca++, ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值