二分搜索求最大值最小化--poj2456

Language:
Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4840 Accepted: 2375

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).  

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C  

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

注意二分搜索的结束条件,在验证是否符合条件时,只需按照贪心看是否可以安排进M头牛即可。

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int x[100010];
int N,M;
bool fun(int mid)
{
    int cnt=1;
    int m=x[1];
    for(int i=2; i<=N; i++)
    {
        if(x[i]-m>=mid)
        {
            cnt++;
            m=x[i];
        }
        if(cnt>=M)
            return true;
    }
    return false;
}
int main()
{   //freopen("in.txt","r",stdin);
    while(cin>>N>>M)
    {
        for(int i=1; i<=N; i++)
            cin>>x[i];
        sort(x+1,x+1+N);
        int l=0,r=x[N],mid;
        while(l+1<r)
        {
            mid=(l+r)/2;
            if(fun(mid))
                l=mid;
            else
                r=mid;
        }
        cout<<l<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值