1140. Look-and-say Sequence (20)

1140. Look-and-say Sequence (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:
1 8
Sample Output:
1123123111


题目大意:第n+1个串是第n个串的描述。   比如第n个串是11122234(随便写的),那么第n+1个串就是13233141,这个意思就是在第n个串中  1有3个, 2有3个, 3有1个, 4有1个, 所以是13233141。 

#include<bits/stdc++.h>
using namespace std;
char d;
int n,len;
string s,temp,ans;
int main(){
    cin>>d>>n;
    s=d;
    int cnt=1,num=0;
    char t;
    while(cnt<n){
        s+="a";
        cnt++;
        len=s.length();
        num=0;
        temp="";
        t=s[0];
        for(int i=0;i<len;i++){
           if(t==s[i])    num++;
            else {
                temp+=t;
                temp+=(char)(num+'0');
                num=0;
                t=s[i];
                i--;
            }
        }
        s=temp;
    }
    cout<<s<<endl;
    return 0;
}



  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值