1020. Tree Traversals (25)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2


IDEA

1.根据后根遍历序列和中根遍历序列,建立二叉树,然后层序遍历二叉树,输出层序遍历序列;

2.用到递归,队列#include<queue>


CODE

#include<iostream>
#include<cstdlib>
#include<queue>
using namespace std;
int pos[31],in[31],level[31];
struct Bitree{
	int data;
	Bitree *left;
	Bitree *right;
};
Bitree *buildBitree(int pos_l,int pos_r,int in_l,int in_r){
	if(pos_l>pos_r){
		return NULL;
	}
	int p=in_l;
	while(in[p]!=pos[pos_r]){
		p++;
	}
	Bitree *tree=(Bitree *)malloc(sizeof(Bitree));
	tree->data=pos[pos_r];
	tree->left=buildBitree(pos_l,p-1-in_l+pos_l,in_l,p-1);//pos_r-in_r+p-1 
	tree->right=buildBitree(pos_r-in_r+p,pos_r-1,p+1,in_r);
	return tree;
}
int levelOrder(Bitree *root){
	queue<Bitree *>que;
	Bitree *p=NULL;
	que.push(root);//将元素插到队尾 
	int flag=1;
	int i=0;
	while(!que.empty()){
		p=que.front();//访问队首元素 
		que.pop();// 弹出队列第一个元素,并不会反悔元素值  
		if(p==NULL){
			continue;
		}
		if(flag){
			level[i++]=p->data;
			flag=0;
		}else{
			level[i++]=p->data;
		}
		que.push(p->left);
		que.push(p->right);
	}
	return i;
}
int main(){
	int n;
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>pos[i];
	}
	for(int i=0;i<n;i++){
		cin>>in[i];
	}
	Bitree *tree;
	tree=buildBitree(0,n-1,0,n-1);//由中序,后序建立起这棵树 
	int len=levelOrder(tree);//层序遍历树 
	for(int i=0;i<len;i++){
		if(i==0){
			cout<<level[i];
		}else{
			cout<<" "<<level[i];
		}
	}
	
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值