[PAT]1020. Tree Traversals (25)@Java

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2


package go.jacob.day1016;

import java.util.ArrayList;
import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;

/**
 * 1020. Tree Traversals (25)
 * 
 * @author Jacob
 *
 */
public class Demo2 {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		int[] postorder = new int[n];
		int[] inorder = new int[n];
		for (int i = 0; i < n; i++)
			postorder[i] = sc.nextInt();
		for (int i = 0; i < n; i++)
			inorder[i] = sc.nextInt();

		Node root = rebuild(postorder, 0, n - 1, inorder, 0, n - 1);
		Queue<Node> queue = new LinkedList<Node>();
		queue.offer(root);
		ArrayList<Integer> res = new ArrayList<Integer>();
		while (!queue.isEmpty()) {
			Node node = queue.poll();
			res.add(node.value);
			if (node.left != null)
				queue.offer(node.left);
			if (node.right != null)
				queue.offer(node.right);
		}
		System.out.print(res.get(0));
		for (int i = 1; i < res.size(); i++) {
			System.out.print(" " + res.get(i));
		}
		sc.close();

	}

	private static Node rebuild(int[] postorder, int postLeft, int postRight, int[] inorder, int inLeft, int inRight) {
//		System.out.println("hhhhhhhhhhh:"+postLeft+" "+postRight+" "+inLeft+" "+inRight);
		if (postLeft > postRight)
			return null;
		Node root = new Node(postorder[postRight]);
		int index = 0;
		for (int i = inLeft; i <= inRight; i++) {
			if (inorder[i] == postorder[postRight])
				index = i;
		}
		int leftNum = index - inLeft;

		root.left = rebuild(postorder, postLeft, postLeft + leftNum - 1, inorder, inLeft, index - 1);
		root.right = rebuild(postorder, postLeft + leftNum, postRight - 1, inorder, index + 1, inRight);
		return root;
	}

	/*
	 * 构造树节点类
	 */
	static class Node {
		public Node(int value) {
			this.value = value;
		}

		int value;
		Node left;
		Node right;
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值