1074. Reversing Linked List (25)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237

68237 6 -1


IDEA

1.注意:可能给出的节点有不在链表上的情况,则这样的几点是不输出的,也就不能用n/k来确定进行了几次翻转

2.思路:将给出的几点按顺序牌号,然后按要求翻转,最后需要把最后一个节点的next赋值为-1


CODE

#include<iostream>
#include<cstdio>
#include<vector> 
#include<queue>
#include<algorithm>
#include<fstream>
using namespace std;
#define Max 100010
struct Node{
	int add;
	int data;
	int next;
};
int main(){
	#ifndef ONLINE_JUDGE
	freopen("input.txt","r",stdin);
	#endif
	
	vector<Node> vec(Max);
	int start,n,k;
	cin>>start>>n>>k;
	for(int i=0;i<n;i++){
		Node node;
		cin>>node.add>>node.data>>node.next;
		vec[node.add]=node;
	}
	vector<Node> tmp;
	int p=start;
	while(p!=-1){
		tmp.push_back(vec[p]);
		p=vec[p].next;
	}
//这样写最后一个测试点通不过,没有考虑有的节点可能不在链表上的情况,不能用n/k确定翻转几次 
//	int m=n/k;
//	for(int i=0;i<m;i++){
//		reverse(tmp.begin()+i*k,tmp.begin()+(i+1)*k);
//	}
	for(int i=0;i+k<=tmp.size();i+=k){
		reverse(tmp.begin()+i,tmp.begin()+i+k);
	}
	for(int i=0;i<tmp.size()-1;i++){
		tmp[i].next=tmp[i+1].add;
	}
	//tmp[tmp.size()-1].next=-1;
	for(int i=0;i<tmp.size();i++){
		if(i!=tmp.size()-1){
			printf("%05d %d %05d\n",tmp[i].add,tmp[i].data,tmp[i].next);
		}else{
			printf("%05d %d -1\n",tmp[i].add,tmp[i].data);
		}
		
	}
	#ifndef ONLINE_JUDGE
	fclose(stdin);
	#endif
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值