PAT 7-2 Reversing Linked List

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

 这个题有点烦, 本来都已经反转完成了, 但是它的输入样例是类似内存中存储的结构, 还要转换一下, 又花了许多时间.

我的代码设计了3个链表, 第一个链表存储反转后的链表, 第二个链表存储暂时反转的结点, 要记录结点的个数, 结点个数达到K个, 就把第二个链表的所有结点接到第一个链表上.第三个链表存储输入的所有数据, 向第二个链表反转, 如果最终第二个链表的结点个数不到K个, 再反转回第三个链表, 第三个链表正序接到第一个链表的尾巴上.

#include <stdio.h>
#include <stdlib.h>

struct Node {
	int index;
	int data;
	int point;
	struct Node* next;
};
typedef struct Node* List;

void printList(List head);
void FreeList(List head);
List reverseK(List head, int K);

int main( void )
{
	int a[100000][2];
	int first, num, K;
	scanf("%d %d %d", &first, &num, &K);
	int index;
	for( int i=0; i<num; i++ ) {
		scanf("%d", &index);
		scanf("%d %d", &a[index][0], &a[index][1]);
	}
//	printf("%d", a[00000][0]);
	List head = (List)malloc(sizeof(struct Node));
	List rear = head;
	List tmp;
	while ( first != -1 ) {
		tmp = (List)malloc(sizeof(struct Node));
		tmp->index = first;
		tmp->data = a[first][0];
		tmp->point = a[first][1];
		first = tmp->point;
		rear->next = tmp;
		rear = rear->next;
	}
	rear->next = NULL;
	tmp = head;
	head = head->next;
	free(tmp);
	List p2 = reverseK(head, K);
	printList(p2);
	FreeList(p2);
	return 0;
}

void printList(List head)
{
	List tmp;
	while ( head->next ) {
		tmp = head;
		tmp->point = tmp->next->index;
		head = head->next;
		printf("%05d %d %05d\n", tmp->index, tmp->data, tmp->point);
	}
	printf("%05d %d -1", head->index, head->data, head->point);
	return;
}

void FreeList(List head)
{
	while ( head ) {
		List tmp = head;
		head = head->next;
		free(tmp);
	}
	return;
}

List reverseK(List head, int K)
{
	List p1 = (List)malloc(sizeof(struct Node));//逆转之后存储的堆栈 
	List p2 = (List)malloc(sizeof(struct Node));//暂时存储K个结点的堆栈 
	p2->next = NULL;
	List r1 = p1;//p1的尾结点,直接把p2的结点往上加 
	List r2 = p2;
	List newhead = (List)malloc(sizeof(struct Node));
	newhead->next = head;
	int cnt = 0;//计数器,按余数循环 
	List tmp;
	while ( newhead->next ) {
		tmp = newhead->next;
		newhead->next = tmp->next;
		tmp->next = p2->next;
		p2->next = tmp;
		if ( !tmp->next )//tmp->Next == 0
			r2 = tmp;
		if ( ++cnt % K == 0 ) {//cnt+=1,再对K求余 
			r1->next = p2->next;
			r1 = r2;
			r2 = p2;
			p2->next = NULL;
		}
	}
	while ( p2->next ) {//p2里面剩下的结点,要逆转回newhead再加到p1 
		tmp = p2->next;
		p2->next = tmp->next;
		tmp->next = newhead->next;
		newhead->next = tmp;
	}
	r1->next = newhead->next;
	tmp = p1;
	p1 = p1->next;
	free(newhead);
	free(p2);
	free(tmp);
	return p1;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目描述 给定一个常数 $K$ 以及一个单链表 $L$,请编写程序将 $L$ 中每 $K$ 个结点反转。例如:给定 $L$ 为 1→2→3→4→5→6,$K$ 为 3,则输出应该为 3→2→1→6→5→4;如果 $K$ 为 4,则输出应该为 4→3→2→1→5→6,即最后不到 $K$ 个元素不反转。 输入格式 每个输入包含一个测试用例。每个测试用例第 1 行给出第 1 个结点的地址、结点总个数正整数 $N (\le 10^5)$、以及正整数 $K (\le N)$,即要求反转的子链结点的个数。结点的地址是 5 位非负整数,NULL 地址用 −1 表示。 接下来有 $N$ 行,每行格式为: Address Data Next 其中 Address 是结点地址;Data 是该结点保存的整数数据;Next 是下一结点的地址。题目保证给出的链表不为空。 输出格式 对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。 输入样例 00100 6 4 00000 4 99999 00100 1 12309 68237 6 -1 33218 3 00000 99999 5 68237 23333 2 33218 输出样例 00000 4 33218 33218 3 12309 12309 1 99999 99999 5 68237 68237 6 23333 23333 2 -1 题目分析 本题需要将链表中每 $K$ 个结点反转,可以采用迭代的方法,每次找到 $K$ 个结点,将这 $K$ 个结点反转,然后将这 $K$ 个结点的前驱结点指向反转后的第一个结点,将反转后的 $K$ 个结点的最后一个结点指向下一个要反转的结点,然后继续进行下一轮反转。 需要注意的是,如果链表长度不足 $K$,则不进行反转。 代码实现

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值