hdu1077 catching fish

Problem Description
Ignatius likes catching fish very much. He has a fishnet whose shape is a circle of radius one. Now he is about to use his fishnet to catch fish. All the fish are in the lake, and we assume all the fish will not move when Ignatius catching them. Now Ignatius wants to know how many fish he can catch by using his fishnet once. We assume that the fish can be regard as a point. So now the problem is how many points can be enclosed by a circle of radius one.

Note: If a fish is just on the border of the fishnet, it is also caught by Ignatius.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a positive integer N(1<=N<=300) which indicate the number of fish in the lake. Then N lines follow. Each line contains two floating-point number X and Y (0.0<=X,Y<=10.0). You may assume no two fish will at the same point, and no two fish are closer than 0.0001, no two fish in a test case are approximately at a distance of 2.0. In other words, if the distance between the fish and the centre of the fishnet is smaller 1.0001, we say the fish is also caught.

Output
For each test case, you should output the maximum number of fish Ignatius can catch by using his fishnet once.

Sample Input

4
3
6.47634 7.69628
5.16828 4.79915
6.69533 6.20378
6
7.15296 4.08328
6.50827 2.69466
5.91219 3.86661
5.29853 4.16097
6.10838 3.46039
6.34060 2.41599
8
7.90650 4.01746
4.10998 4.18354
4.67289 4.01887
6.33885 4.28388
4.98106 3.82728
5.12379 5.16473
7.84664 4.67693
4.02776 3.87990
20
6.65128 5.47490
6.42743 6.26189
6.35864 4.61611
6.59020 4.54228
4.43967 5.70059
4.38226 5.70536
5.50755 6.18163
7.41971 6.13668
6.71936 3.04496
5.61832 4.23857
5.99424 4.29328
5.60961 4.32998
6.82242 5.79683
5.44693 3.82724
6.70906 3.65736
7.89087 5.68000
6.23300 4.59530
5.92401 4.92329
6.24168 3.81389
6.22671 3.62210

Sample Output

2
5
5
11
题意:

给你好多点的坐标,让你用一个半径为1的圆围进去最多的点

因为点很少,所以我的方式是根据点对的坐标枚举圆心的位置,让圆的边刚好能覆盖到两个点。任取两个点p1(x1,y1),p2(x2,y2) ,可以知道有两个圆心,并且在p1,p2连线的中垂线上,勾股定理求出p1p2中点到圆心的距离,用参数方程可以求出圆心的坐标,然后用圆心的坐标去比较和每个点的距离是不是1以内就可以了。
代码:

#include <iostream>
#include <math.h>
using namespace std;
typedef struct P
{
    double x;
    double y;
};
double dist(P p1,P p2)
{
    return sqrt((p1.y-p2.y)*(p1.y-p2.y)+(p1.x-p2.x)*(p1.x-p2.x));
}
double gett(P p1,P p2)
{
   return  sqrt(1-(dist(p1,p2)/2)*(dist(p1,p2)/2));
}


double getsita(P p1,P p2)
{
    double sita;
    sita=atan(-(p1.x-p2.x)/(p1.y-p2.y));
    return sita;
}


int main()
{
    int n,i,j,ans,num,k;
    double x1,y1,x2,y2,xm,ym,sita,t;
    P temp,p[400],mid;
    int T;
    cin>>T;
    while (T--)
    {
    cin>>n;
    ans=1;
    for (i=1;i<=n;i++) cin>>p[i].x>>p[i].y;

    for (i=1;i<=n;i++)
        for (j=i+1;j<=n;j++)
    if (dist(p[i],p[j])<1.0001*2)
    {
       xm=(p[i].x+p[j].x)/2;
       ym=(p[i].y+p[j].y)/2;
       mid.x=xm;
       mid.y=ym;
       t=gett(p[i],p[j]);
       sita=getsita(p[i],p[j]);
      // cout<<xm<<" "<<ym<<" "<<t<<" "<<sita<<endl;
       x1=xm+cos(sita)*t;
       y1=ym+sin(sita)*t;
       x2=xm-cos(sita)*t;
       y2=ym-sin(sita)*t;
       temp.x=x1;
       temp.y=y1;
       num=0;
     // cout<<temp.x<<" "<<temp.y<<endl;
       for (k=1;k<=n;k++)
        {

            if (dist(temp,p[k])<1.0001) num++;
        }
        if (num>ans) ans=num;


        temp.x=x2;
       temp.y=y2;
       num=0;
     //  cout<<temp.x<<" "<<temp.y<<endl;
       for (k=1;k<=n;k++)
        {

            if (dist(temp,p[k])<1.0001) num++;
        }
        if (num>ans) ans=num;
    }
    cout<<ans<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值