PAT 1091. Acute Stroke (30)

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M by N matrix, and the maximum resolution is 1286 by 128); L (<=60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M by N matrix of 0’s and 1’s, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1’s to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are “connected” and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.

Figure 1
Figure 1
Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:
3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0
Sample Output:
26

思路
这道题如果破解了英文“密码”,实际就是一道求三维矩阵里连通路径的问题!不过特意做题解是因为有个非常简便的搜索方法:用dx,dy,dz三个向量来写优雅的代码
vector<int> dx {1,-1,0,0,0,0};
vector<int> dy {0,0,1,-1,0,0};
vector<int> dz {0,0,0,0,1,-1};
//对于一个点,要遍历其周围上下左右前后六个方向,只需要一个循环
point p(x,y,z);
int xx = p.x;
int yy = p.y;
int zz = p.z;
for(int i=0 ; i<6 ; i++){
    visit(point(xx+dx[i],yy+dy[i],zz+dz[i]);
}

下面是参考了这位牛人的blog的代码

#include<iostream>
#include<algorithm>
#include<vector>
#include<fstream>
#include<limits.h>
#include<queue> 
using namespace std;

int n,m,s,t;
vector<vector<vector<int > > > map;
int ret = 0;//result
bool inRange(int& x, int& y, int& z){
    return ((x<n)&&(x>=0)&&(y<m)&&(y>=0)&&(z<s)&&(z>=0));
}

struct loc{
    int x;
    int y;
    int z;
    loc(int x, int y, int z):x(x),y(y),z(z){}
};

int dx[6] = {1,-1,0,0,0,0};
int dy[6] = {0,0,1,-1,0,0};
int dz[6] = {0,0,0,0,1,-1};

void bfs(int x,int y, int z){
    queue<loc>  q;
    int ans = 0;
    q.push(loc(x,y,z));
    ans++;
    map[x][y][z] = 0;

    while(!q.empty()){
        int xx = q.front().x;
        int yy = q.front().y;
        int zz = q.front().z;
        q.pop();

        for(int i = 0 ; i<6 ; i++){
            int nx = xx+dx[i];
            int ny = yy+dy[i];
            int nz = zz+dz[i];
            if (inRange(nx,ny,nz )&&map[nx][ny][nz]){
                map[nx][ny][nz] = 0;
                q.push(loc(nx,ny,nz));
                ans++;
            }
        }
    }

    if (ans>=t)
        ret+=ans;
}

int main(){
    cin >> n >> m >> s >> t;
    map.resize(n);
    for (int i=0 ; i<n ; i++){
        map[i].resize(m);
    }
    for (int i=0 ; i<n ; i++){
        for (int j=0 ; j<m ; j++){
            map[i][j].resize(s,0);
        }
    }
    for (int k=0 ; k<s ; k++){
        for (int i=0 ; i<n ; i++){
            for (int j=0 ; j<m ; j++){
                cin >> map[i][j][k];
            }
        }
    }

    for (int k=0 ; k<s ; k++){
        for (int i=0 ; i<n ; i++){
            for (int j=0 ; j<m ; j++){
                if (map[i][j][k])
                    bfs(i,j,k);
            }
        }
    }
    cout << ret;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值