练习二1013,1014


A strange lift
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 122   Accepted Submission(s) : 22
Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 &lt;= Ki &lt;= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button &quot;UP&quot; , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button &quot;DOWN&quot; , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button &quot;UP&quot;, and you'll go up to the 4 th floor,and if you press the button &quot;DOWN&quot;, the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.<br>Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button &quot;UP&quot; or &quot;DOWN&quot;?<br>
 

Input
The input consists of several test cases.,Each test case contains two lines.<br>The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.<br>A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
  
  
5 1 5<br>3 3 1 2 5<br>0
 

Sample Output
  
  
3
 

题意:一电梯,每一层有两个按钮,向上和向下,并且只能走指定的层数,现在给定电梯层数,初末位置,以及每层电梯能够移动的层数,求从初位置到末位置的最少按按钮次数。
思路:比较简单,用广搜搜到的第一个即为最少。
代码:
#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
int n,a,b,k[201],vis[201];
struct floor
{
 int fl,mov;
}f1,f2;
int bfs(int x,int y)
{
 queue<floor>q;
 f1.fl=x;
 f1.mov=0;
 q.push(f1);
 while(!q.empty()){
 f1=q.front();
 q.pop();
 if(f1.fl==y)
  break;
 if(f1.fl+k[f1.fl]<=n&&!vis[f1.fl+k[f1.fl]])
 {
  vis[f1.fl+k[f1.fl]]=1;
  f2.fl=f1.fl+k[f1.fl];
  f2.mov=f1.mov+1;
  q.push(f2);
 }
 if(f1.fl-k[f1.fl]>=1&&!vis[f1.fl-k[f1.fl]])
 {
  vis[f1.fl-k[f1.fl]]=1;
  f2.fl=f1.fl-k[f1.fl];
  f2.mov=f1.mov+1;
  q.push(f2);
 }
 }
 if(f1.fl==y) return f1.mov;
 else return -1;
}
int main()
{
 while(cin>>n&&n)
 {
  cin>>a>>b;
  for(int i=1;i<=n;i++)
   cin>>k[i];
  memset(vis,0,sizeof(vis));
  vis[a]=1;
  cout<<bfs(a,b)<<endl;
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值