hdu 4300 很好的hash字符串题



Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7455    Accepted Submission(s): 2772


Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 

Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;
 

Output
For each test case, output one line contains the shorest possible complete text.
 

Sample Input
  
  
2 abcdefghijklmnopqrstuvwxyz abcdab qwertyuiopasdfghjklzxcvbnm qwertabcde
 

Sample Output
  
  
abcdabcd qwertabcde
 

Author
BUPT
 

Source

题意:给定两个字符串,第一个字符串为字符串的转换规则,(如第二个例子,当第二个字符串中出现q字符后,就要把它变为a字符,即q对应a,w对应b)。

第二个字符串,前一部分为密文,就是需要你按照转换规则,转换的字符串,后一部分为原文。但是原文的长度不知道,也可能原文给的不全,但是密文是完整的。需要你补全第二个字符串。

思路:密文最短为第二个字符串长度的一半,可以先把整个字符串当做密文处理,这时只要比较原来的第二个字符串的后缀和转换后的前缀就可以了。需要找到最长前缀。

(hash字符串的资料比较少,当初就是看了点资料,就硬搞这道题,慢慢就懂hash了,万事开头难)。

代码:

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
typedef unsigned long long ull;
const int N = 1e5+5;
const int X = 163;
ull hash1[N], hash2[N], p[N];
char previous[N], after[N];
int c[30];
void init() {
    p[0] = 1;
    for(int i = 1; i <= N - 5; i++)
        p[i] = p[i-1]*X;    
}

ull get(int l, int r, ull g[]) {
    return g[r] - g[l-1]*p[r-l+1];
}

void judge() {
    int index;
    int length = strlen(previous);
    for(int i = 0; i < length; i++)
        c[previous[i]-'a'] = i;
    length = strlen(after);
    hash1[0] = hash2[0] = 0;
    for(int i = 1; i <= length; i++) {
        hash1[i] = hash1[i-1]*X + (after[i-1]-'a');
        hash2[i] = hash2[i-1]*X + c[after[i-1]-'a'];
    }
    int mid, te;
    ull hs1, hs2;
    index = length;
    for(int i = length; i < length*2; i++) {
        if(i&1)
            continue;
        mid = i/2;
        te = length - mid;
        hs1 = get(length-te+1, length, hash1);
        hs2 = get(1, te, hash2);
        if(hs1 == hs2) {
            index = mid;
            break;
        }
    }
    for(int i = 0; i < index; i++)
        printf("%c", after[i]);
    for(int i = 0; i < index; i++) 
        printf("%c", c[after[i]-'a']+'a');
    printf("\n");
}

int main() {
    int t;
    init();
    scanf("%d", &t);
    while(t--) {
        scanf("%s%s", previous, after);
        judge();
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值