hdu 1880(hash字符串+二分查找)



魔咒词典

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14654    Accepted Submission(s): 3525


Problem Description
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
 

Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
 

Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
 

Sample Input
  
  
[expelliarmus] the disarming charm [rictusempra] send a jet of silver light to hit the enemy [tarantallegra] control the movement of one's legs [serpensortia] shoot a snake out of the end of one's wand [lumos] light the wand [obliviate] the memory charm [expecto patronum] send a Patronus to the dementors [accio] the summoning charm @END@ 4 [lumos] the summoning charm [arha] take me to the sky
 

Sample Output
  
  
light the wand accio what? what?
 

Author
ZJU
 

Source
思路:BDKR_hash字符串 + 二分查找。本来可以写的短一些,现在感觉贼垃圾。


代码:

#include <stdio.h>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>
#include<queue>
#include<iostream>
#include<list>
using namespace std;
typedef unsigned long long ull;
const int N = 1e5+7;
const int X = 163;
struct node1 {
    char tname[30];
    ull product;
}hhash1[N];
struct node2 {
    char tproduct[90];
    ull name;    
}hhash2[N];
int cmp1(node1 a, node1 b) {
    return a.product < b.product;
}
int cmp2(node2 a, node2 b) {
    return a.name < b.name;
}
int binary_search1(ull sum, int &flag, int num) {
    int left = 0, mid, right = num;
    while(left <= right) {
        mid = (left + right)/2;
        if(hhash2[mid].name > sum)
            right = mid - 1;
        else if(hhash2[mid].name < sum)
            left = mid + 1;
        else {
            flag = 1;
            return mid;
        }
    }
    return 0;
}
int binary_search2(ull sum, int &flag, int num) {
    int left = 0, mid, right = num;
    while(left <= right) {
        mid = (left + right)/2;
        if(hhash1[mid].product > sum)
            right = mid - 1;
        else if(hhash1[mid].product < sum)
            left = mid + 1;
        else {
            flag = 1;
            return mid;
        }
    }
    return 0;
}
int n;
int main() {
    int count = 0, len;
    ull sum = 0;
    char s[100];
    while(scanf("%s",hhash1[count].tname)) {
        getchar();
        if(strcmp(hhash1[count].tname, "@END@") == 0)
            break;
        gets(hhash2[count].tproduct);
        sum = 0;
        len = strlen(hhash1[count].tname);
        for(int i = 1; i < len - 1; i++)
            sum = sum * X + (hhash1[count].tname[i] - ' ');
        hhash2[count].name = sum;
        sum = 0;
        len = strlen(hhash2[count].tproduct);
        for(int i = 0; i < len; i++)
            sum = sum * X + (hhash2[count].tproduct[i] - ' ');
        hhash1[count].product = sum;
        count++;
    }
    scanf("%d", &n);
    sort(hhash1, hhash1+count, cmp1);
    sort(hhash2, hhash2+count, cmp2);
    int index, flag;
    getchar();
    for(int i = 1; i <= n; i++) {
        gets(s);
        sum = 0;
        flag = 0;
        if(s[0] == '[') {
            len = strlen(s);
            for(int j = 1; j < len - 1; j++)
                sum = sum * X + (s[j] - ' ');
            index = binary_search1(sum, flag, count-1);
            if(flag) {
                printf("%s\n", hhash2[index].tproduct);
            }
            else
                printf("what?\n");
        }
        else {
            len = strlen(s);
            for(int j = 0; j < len; j++)
                sum = sum * X + (s[j] - ' ');
            index = binary_search2(sum, flag, count-1);
            if(flag) {
                len = strlen(hhash1[index].tname);
                for(int k = 1; k < len -1; k++)
                    printf("%c", hhash1[index].tname[k]);
                printf("\n");
            }
            else
                printf("what?\n");
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值